Ethernet

IP over Ethernet, Ethernet interworking and OAM

Ethernet RFCs (149)

Display RFCs as
  • RFC 10018: Multicast and Ethernet VPN with Segment Routing Point-to-Multipoint (P2MP) and Ingress Replication

    Proposed Standard
  • RFC 10031: Media Access Control (MAC) Addresses in X.509 Certificates

    Proposed Standard
  • Proposed Standard
  • Proposed Standard
  • RFC 9784: Virtual Ethernet Segments for EVPN and Provider Backbone Bridge EVPN

    Proposed Standard
  • RFC 9721: Extended Mobility Procedures for Ethernet VPN Integrated Routing and Bridging (EVPN-IRB)

    Proposed Standard
  • RFC 9574: Optimized Ingress Replication Solution for Ethernet VPNs (EVPNs)

    Proposed Standard
  • RFC 9542: BCP 141: IANA Considerations and IETF Protocol and Documentation Usage for IEEE 802 Parameters

    Best Current Practice
  • RFC 9541: Flush Mechanism for Customer MAC Addresses Based on Service Instance Identifier (I-SID) in Provider Backbone Bridging EVPN (PBB-EVPN)

    Proposed Standard
  • RFC 9469: Applicability of Ethernet Virtual Private Network (EVPN) to Network Virtualization over Layer 3 (NVO3) Networks

    Informational
  • RFC 9251: Internet Group Management Protocol (IGMP) and Multicast Listener Discovery (MLD) Proxies for Ethernet VPN (EVPN)

    Proposed Standard
  • RFC 9161: Operational Aspects of Proxy ARP/ND in Ethernet Virtual Private Networks

    Proposed Standard
  • RFC 9135: Integrated Routing and Bridging in Ethernet VPN (EVPN)

    Proposed Standard
  • RFC 9136: IP Prefix Advertisement in Ethernet VPN (EVPN)

    Proposed Standard
  • RFC 9039: Uniform Resource Names for Device Identifiers

    Proposed Standard
  • RFC 9062: Framework and Requirements for Ethernet VPN (EVPN) Operations, Administration, and Maintenance (OAM)

    Informational
  • RFC 9047: Propagation of ARP/ND Flags in an Ethernet Virtual Private Network (EVPN)

    Proposed Standard
  • RFC 9023: Deterministic Networking (DetNet) Data Plane: IP over IEEE 802.1 Time-Sensitive Networking (TSN)

    Informational
  • RFC 9024: Deterministic Networking (DetNet) Data Plane: IEEE 802.1 Time-Sensitive Networking over MPLS

    Proposed Standard
  • RFC 9037: Deterministic Networking (DetNet) Data Plane: MPLS over IEEE 802.1 Time-Sensitive Networking (TSN)

    Informational
  • RFC 9030: An Architecture for IPv6 over the Time-Slotted Channel Hopping Mode of IEEE 802.15.4 (6TiSCH)

    Informational
  • RFC 9014: Interconnect Solution for Ethernet VPN (EVPN) Overlay Networks

    Proposed Standard
  • RFC 9011: Static Context Header Compression and Fragmentation (SCHC) over LoRaWAN

    Proposed Standard
  • RFC 9006: TCP Usage Guidance in the Internet of Things (IoT)

    Informational
  • RFC 8948: Structured Local Address Plan (SLAP) Quadrant Selection Option for DHCPv6

    Proposed Standard
  • RFC 8772: The China Mobile, Huawei, and ZTE Broadband Network Gateway (BNG) Simple Control and User Plane Separation Protocol (S-CUSP)

    Informational
  • RFC 8724: SCHC: Generic Framework for Static Context Header Compression and Fragmentation

    Proposed Standard
  • RFC 8625: Ethernet Traffic Parameters with Availability Information

    Proposed Standard
  • RFC 8560: Seamless Integration of Ethernet VPN (EVPN) with Virtual Private LAN Service (VPLS) and Their Provider Backbone Bridge (PBB) Equivalents

    Proposed Standard
  • RFC 8584: Framework for Ethernet VPN Designated Forwarder Election Extensibility

    Proposed Standard
  • RFC 8469: Recommendation to Use the Ethernet Control Word

    Proposed Standard
  • Proposed Standard
  • RFC 8388: Usage and Applicability of BGP MPLS-Based Ethernet VPN

    Informational
  • RFC 8365: A Network Virtualization Overlay Solution Using Ethernet VPN (EVPN)

    Proposed Standard
  • RFC 8317: Ethernet-Tree (E-Tree) Support in Ethernet VPN (EVPN) and Provider Backbone Bridging EVPN (PBB-EVPN)

    Proposed Standard
  • RFC 8214: Virtual Private Wire Service Support in Ethernet VPN

    Proposed Standard
  • Proposed Standard
  • RFC 8180: BCP 210: Minimal IPv6 over the TSCH Mode of IEEE 802.15.4e (6TiSCH) Configuration

    Best Current Practice
  • RFC 8137: IEEE 802.15.4 Information Element for the IETF

    Informational
  • Proposed Standard
  • RFC 7844: Anonymity Profiles for DHCP Clients

    Proposed Standard
  • RFC 7796: Ethernet-Tree (E-Tree) Support in Virtual Private LAN Service (VPLS)

    Proposed Standard
  • RFC 7731: Multicast Protocol for Low-Power and Lossy Networks (MPL)

    Proposed Standard
  • RFC 7734: Support for Shortest Path Bridging MAC Mode over Ethernet VPN (EVPN)

    Proposed Standard
  • RFC 7593: The eduroam Architecture for Network Roaming

    Informational
  • RFC 7623: Provider Backbone Bridging Combined with Ethernet VPN (PBB-EVPN)

    Proposed Standard
  • RFC 7554: Using IEEE 802.15.4e Time-Slotted Channel Hopping (TSCH) in the Internet of Things (IoT): Problem Statement

    Informational
  • RFC 7432: BGP MPLS-Based Ethernet VPN

    Proposed Standard
  • RFC 7448: MIB Transfer from the IETF to the IEEE 802.3 WG

    Informational
  • RFC 7400: 6LoWPAN-GHC: Generic Header Compression for IPv6 over Low-Power Wireless Personal Area Networks (6LoWPANs)

    Proposed Standard
  • RFC 7387: A Framework for Ethernet Tree (E-Tree) Service over a Multiprotocol Label Switching (MPLS) Network

    Informational
  • RFC 7369: GMPLS RSVP-TE Extensions for Ethernet Operations, Administration, and Maintenance (OAM) Configuration

    Proposed Standard
  • RFC 7361: LDP Extensions for Optimized MAC Address Withdrawal in a Hierarchical Virtual Private LAN Service (H-VPLS)

    Proposed Standard
  • Proposed Standard
  • RFC 7260: GMPLS RSVP-TE Extensions for Operations, Administration, and Maintenance (OAM) Configuration

    Proposed Standard
  • RFC 7213: MPLS Transport Profile (MPLS-TP) Next-Hop Ethernet Addressing

    Proposed Standard
  • RFC 7271: MPLS Transport Profile (MPLS-TP) Linear Protection to Match the Operational Expectations of Synchronous Digital Hierarchy, Optical Transport Network, and Ethernet Transport Network Operators

    Proposed Standard
  • RFC 7209: Requirements for Ethernet VPN (EVPN)

    Informational
  • Proposed Standard
  • Proposed Standard
  • RFC 7152: Requirements for Metro Ethernet Forum (MEF) Ethernet-Tree (E-Tree) Support in Layer 2 Virtual Private Network (L2VPN)

    Informational
  • RFC 7124: Ethernet in the First Mile Copper (EFMCu) Interfaces MIB

    Proposed Standard
  • RFC 7042: IANA Considerations and IETF Protocol and Documentation Usage for IEEE 802 Parameters

    Best Current Practice

    Obsoleted by RFC 9542

  • RFC 7043: Resource Records for EUI-48 and EUI-64 Addresses in the DNS

    Informational
  • RFC 7023: MPLS and Ethernet Operations, Administration, and Maintenance (OAM) Interworking

    Proposed Standard
  • RFC 6767: Ethernet-Based xDSL Multi-Pair Bonding (G.Bond/Ethernet) MIB

    Proposed Standard
  • Informational
  • RFC 6606: Problem Statement and Requirements for IPv6 over Low-Power Wireless Personal Area Network (6LoWPAN) Routing

    Informational
  • RFC 6329: IS-IS Extensions Supporting IEEE 802.1aq Shortest Path Bridging

    Proposed Standard
  • RFC 6282: Compression Format for IPv6 Datagrams over IEEE 802.15.4-Based Networks

    Proposed Standard
  • RFC 6060: Generalized Multiprotocol Label Switching (GMPLS) Control of Ethernet Provider Backbone Traffic Engineering (PBB-TE)

    Proposed Standard
  • RFC 6085: Address Mapping of IPv6 Multicast Packets on Ethernet

    Proposed Standard
  • RFC 6003: Ethernet Traffic Parameters

    Proposed Standard
  • RFC 6004: Generalized MPLS (GMPLS) Support for Metro Ethernet Forum and G.8011 Ethernet Service Switching

    Proposed Standard
  • RFC 6005: Generalized MPLS (GMPLS) Support for Metro Ethernet Forum and G.8011 User Network Interface (UNI)

    Proposed Standard
  • RFC 5994: Application of Ethernet Pseudowires to MPLS Transport Networks

    Informational
  • RFC 5948: Transmission of IPv4 Packets over the IP Convergence Sublayer of IEEE 802.16

    Proposed Standard
  • RFC 5904: RADIUS Attributes for IEEE 802.16 Privacy Key Management Version 1 (PKMv1) Protocol Support

    Informational
  • RFC 5828: Generalized Multiprotocol Label Switching (GMPLS) Ethernet Label Switching Architecture and Framework

    Informational
  • RFC 5517: Cisco Systems' Private VLANs: Scalable Security in a Multi-Client Environment

    Informational
  • RFC 5692: Transmission of IP over Ethernet over IEEE 802.16 Networks

    Proposed Standard
  • RFC 5603: Ethernet Pseudowire (PW) Management Information Base (MIB)

    Proposed Standard
  • Informational
  • RFC 5501: Requirements for Multicast Support in Virtual Private LAN Services

    Informational
  • RFC 5342: IANA Considerations and IETF Protocol Usage for IEEE 802 Parameters

    Best Current Practice

    Obsoleted by RFC 7042

  • RFC 5270: Mobile IPv6 Fast Handovers over IEEE 802.16e Networks

    Informational
  • RFC 5181: IPv6 Deployment Scenarios in 802.16 Networks

    Informational
  • Informational
  • RFC 5154: IP over IEEE 802.16 Problem Statement and Goals

    Informational
  • RFC 5121: Transmission of IPv6 via the IPv6 Convergence Sublayer over IEEE 802.16 Networks

    Proposed Standard
  • RFC 5066: Ethernet in the First Mile Copper (EFMCu) Interfaces MIB

    Proposed Standard
  • RFC 4944: Transmission of IPv6 Packets over IEEE 802.15.4 Networks

    Proposed Standard
  • RFC 4919: IPv6 over Low-Power Wireless Personal Area Networks (6LoWPANs): Overview, Assumptions, Problem Statement, and Goals

    Informational
  • Informational
  • RFC 4837: Managed Objects of Ethernet Passive Optical Networks (EPON)

    Proposed Standard
  • RFC 4878: Definitions and Managed Objects for Operations, Administration, and Maintenance (OAM) Functions on Ethernet-Like Interfaces

    Proposed Standard
  • RFC 4836: Definitions of Managed Objects for IEEE 802.3 Medium Attachment Units (MAUs)

    Proposed Standard
  • RFC 4719: Transport of Ethernet Frames over Layer 2 Tunneling Protocol Version 3 (L2TPv3)

    Proposed Standard
  • RFC 4663: Transferring MIB Work from IETF Bridge MIB WG to IEEE 802.1 WG

    Informational
  • RFC 4554: Use of VLANs for IPv4-IPv6 Coexistence in Enterprise Networks

    Informational
  • RFC 4562: MAC-Forced Forwarding: A Method for Subscriber Separation on an Ethernet Access Network

    Informational
  • RFC 4448: Encapsulation Methods for Transport of Ethernet over MPLS Networks

    Proposed Standard
  • RFC 4363: Definitions of Managed Objects for Bridges with Traffic Classes, Multicast Filtering, and Virtual LAN Extensions

    Proposed Standard
  • RFC 4318: Definitions of Managed Objects for Bridges with Rapid Spanning Tree Protocol

    Proposed Standard
  • RFC 4188: Definitions of Managed Objects for Bridges

    Proposed Standard
  • RFC 3621: Power Ethernet MIB

    Proposed Standard
  • RFC 3619: Extreme Networks' Ethernet Automatic Protection Switching (EAPS) Version 1

    Informational
  • RFC 3635: Definitions of Managed Objects for the Ethernet-like Interface Types

    Proposed Standard
  • RFC 3636: Definitions of Managed Objects for IEEE 802.3 Medium Attachment Units (MAUs)

    Proposed Standard

    Obsoleted by RFC 4836

  • RFC 3637: Definitions of Managed Objects for the Ethernet WAN Interface Sublayer

    Proposed Standard
  • RFC 3638: Applicability Statement for Reclassification of RFC 1643 to Historic Status

    Informational
  • RFC 3580: IEEE 802.1X Remote Authentication Dial In User Service (RADIUS) Usage Guidelines

    Informational
  • RFC 3422: Forwarding Media Access Control (MAC) Frames over Multiple Access Protocol over Synchronous Optical Network/Synchronous Digital Hierarchy (MAPOS)

    Informational
  • RFC 3378: EtherIP: Tunneling Ethernet Frames in IP Datagrams

    Informational
  • RFC 3293: General Switch Management Protocol (GSMP) Packet Encapsulations for Asynchronous Transfer Mode (ATM), Ethernet and Transmission Control Protocol (TCP)

    Proposed Standard
  • RFC 3069: VLAN Aggregation for Efficient IP Address Allocation

    Informational
  • RFC 2892: The Cisco SRP MAC Layer Protocol

    Informational
  • RFC 2641: Cabletron's VlanHello Protocol Specification Version 4

    Informational
  • RFC 2643: Cabletron's SecureFast VLAN Operational Model

    Informational
  • RFC 2665: Definitions of Managed Objects for the Ethernet-like Interface Types

    Proposed Standard

    Obsoleted by RFC 3635

  • RFC 2666: Definitions of Object Identifiers for Identifying Ethernet Chip Sets

    Informational
  • RFC 2668: Definitions of Managed Objects for IEEE 802.3 Medium Attachment Units (MAUs)

    Proposed Standard

    Obsoleted by RFC 3636

  • RFC 2674: Definitions of Managed Objects for Bridges with Traffic Classes, Multicast Filtering and Virtual LAN Extensions

    Proposed Standard

    Obsoleted by RFC 4363

  • RFC 2464: Transmission of IPv6 Packets over Ethernet Networks

    Proposed Standard
  • RFC 2358: Definitions of Managed Objects for the Ethernet-like Interface Types

    Proposed Standard

    Obsoleted by RFC 2665

  • RFC 2340: Nortel's Virtual Network Switching (VNS) Overview

    Informational
  • RFC 2266: Definitions of Managed Objects for IEEE 802.12 Repeater Devices

    Proposed Standard
  • RFC 2239: Definitions of Managed Objects for IEEE 802.3 Medium Attachment Units (MAUs) using SMIv2

    Proposed Standard

    Obsoleted by RFC 2668

  • RFC 2108: Definitions of Managed Objects for IEEE 802.3 Repeater Devices using SMIv2

    Proposed Standard
  • RFC 2020: IEEE 802.12 Interface MIB

    Proposed Standard
  • RFC 1972: A Method for the Transmission of IPv6 Packets over Ethernet Networks

    Proposed Standard

    Obsoleted by RFC 2464

  • RFC 1650: Definitions of Managed Objects for the Ethernet-like Interface Types using SMIv2

    Proposed Standard

    Obsoleted by RFC 2358

  • RFC 1643: Definitions of Managed Objects for the Ethernet-like Interface Types

    Historic

    Obsoleted by RFC 3638

  • RFC 1623: Definitions of Managed Objects for the Ethernet-like Interface Types

    Historic

    Obsoleted by RFC 1643

  • RFC 1515: Definitions of Managed Objects for IEEE 802.3 Medium Attachment Units (MAUs)

    Proposed Standard

    Obsoleted by RFC 3636

  • RFC 1516: Definitions of Managed Objects for IEEE 802.3 Repeater Devices

    Draft Standard

    Obsoleted by RFC 2108

  • RFC 1525: Definitions of Managed Objects for Source Routing Bridges

    Historic
  • RFC 1493: Definitions of Managed Objects for Bridges

    Draft Standard

    Obsoleted by RFC 4188

  • RFC 1398: Definitions of Managed Objects for the Ethernet-Like Interface Types

    Draft Standard

    Obsoleted by RFC 1623

  • RFC 1368: Definition of Managed Objects for IEEE 802.3 Repeater Devices

    Proposed Standard

    Obsoleted by RFC 1516

  • RFC 1369: Implementation Notes and Experience for the Internet Ethernet MIB

    Informational
  • RFC 1284: Definitions of Managed Objects for the Ethernet-like Interface Types

    Proposed Standard

    Obsoleted by RFC 1398

  • RFC 1286: Definitions of Managed Objects for Bridges

    Proposed Standard

    Obsoleted by RFC 1493, RFC 1525

  • RFC 1089: SNMP over Ethernet

    Unknown

    Obsoleted by RFC 4789

  • RFC 1044: STD 45: Internet Protocol on Network System's HYPERchannel: Protocol Specification

    Internet Standard
  • RFC 948: Two methods for the transmission of IP datagrams over IEEE 802.3 networks

    Unknown

    Obsoleted by RFC 1042

  • RFC 894: STD 41: A Standard for the Transmission of IP Datagrams over Ethernet Networks

    Internet Standard
  • RFC 895: STD 42: Standard for the transmission of IP datagrams over experimental Ethernet networks

    Internet Standard
  • RFC 826: STD 37: An Ethernet Address Resolution Protocol: Or Converting Network Protocol Addresses to 48.bit Ethernet Address for Transmission on Ethernet Hardware

    Internet Standard

Subscribe to Ethernet

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.