IS-IS

The IS-IS (Intermediate System to Intermediate System) link-state routing protocol

IS-IS RFCs (103)

Display RFCs as
  • RFC 9933: Carrying SR-Algorithm in Path Computation Element Communication Protocol (PCEP)

    Proposed Standard
  • RFC 9929: IGP Unreachable Prefix Announcement

    Proposed Standard
  • RFC 9917: IGP Flexible Algorithms Reverse Affinity Constraint

    Proposed Standard
  • RFC 9902: A YANG Data Model for IS-IS Segment Routing over the MPLS Data Plane

    Proposed Standard
  • RFC 9885: Multi-Part TLVs in IS-IS

    Proposed Standard
  • RFC 9843: IGP Flexible Algorithms: Bandwidth, Delay, Metrics, and Constraints

    Proposed Standard
  • RFC 9717: A Routing Architecture for Satellite Networks

    Informational
  • RFC 9681: IS-IS Fast Flooding

    Experimental
  • RFC 9655: Egress Validation in Label Switched Path Ping and Traceroute Mechanisms

    Proposed Standard
  • RFC 9666: Area Proxy for IS-IS

    Experimental
  • RFC 9667: Dynamic Flooding on Dense Graphs

    Experimental
  • Proposed Standard
  • RFC 9502: IGP Flexible Algorithm in IP Networks

    Proposed Standard
  • Proposed Standard
  • RFC 9377: IS-IS Flood Reflection

    Experimental
  • RFC 9350: IGP Flexible Algorithm

    Proposed Standard
  • Proposed Standard
  • RFC 9352: IS-IS Extensions to Support Segment Routing over the IPv6 Data Plane

    Proposed Standard
  • RFC 9346: IS-IS Extensions in Support of Inter-Autonomous System (AS) MPLS and GMPLS Traffic Engineering

    Proposed Standard
  • RFC 9130: YANG Data Model for the IS-IS Protocol

    Proposed Standard
  • RFC 9194: A YANG Module for IS-IS Reverse Metric

    Proposed Standard
  • RFC 9314: YANG Data Model for Bidirectional Forwarding Detection (BFD)

    Proposed Standard
  • Proposed Standard
  • Proposed Standard
  • RFC 9160: Export of MPLS Segment Routing Label Type Information in IP Flow Information Export (IPFIX)

    Informational
  • RFC 9127: YANG Data Model for Bidirectional Forwarding Detection (BFD)

    Proposed Standard
  • RFC 9088: Signaling Entropy Label Capability and Entropy Readable Label Depth Using IS-IS

    Proposed Standard
  • Proposed Standard
  • Proposed Standard

    Obsoleted by RFC 9479

  • RFC 8918: Invalid TLV Handling in IS-IS

    Proposed Standard
  • RFC 8706: Restart Signaling for IS-IS

    Proposed Standard
  • RFC 8667: IS-IS Extensions for Segment Routing

    Proposed Standard
  • Proposed Standard
  • RFC 8541: Impact of Shortest Path First (SPF) Trigger and Delay Strategies on IGP Micro-loops

    Informational
  • RFC 8570: IS-IS Traffic Engineering (TE) Metric Extensions

    Proposed Standard
  • RFC 8500: IS-IS Routing with Reverse Metric

    Proposed Standard
  • RFC 8491: Signaling Maximum SID Depth (MSD) Using IS-IS

    Proposed Standard
  • RFC 8401: Bit Index Explicit Replication (BIER) Support via IS-IS

    Proposed Standard
  • RFC 8196: IS-IS Autoconfiguration

    Proposed Standard
  • RFC 8202: IS-IS Multi-Instance

    Proposed Standard
  • RFC 7981: IS-IS Extensions for Advertising Router Information

    Proposed Standard
  • RFC 7987: IS-IS Minimum Remaining Lifetime

    Proposed Standard
  • RFC 7883: Advertising Seamless Bidirectional Forwarding Detection (S-BFD) Discriminators in IS-IS

    Proposed Standard
  • RFC 7917: Advertising Node Administrative Tags in IS-IS

    Proposed Standard
  • RFC 7813: IS-IS Path Control and Reservation

    Proposed Standard
  • RFC 7810: IS-IS Traffic Engineering (TE) Metric Extensions

    Proposed Standard

    Obsoleted by RFC 8570

  • RFC 7794: IS-IS Prefix Attributes for Extended IPv4 and IPv6 Reachability

    Proposed Standard
  • RFC 7775: IS-IS Route Preference for Extended IP and IPv6 Reachability

    Proposed Standard
  • Proposed Standard
  • RFC 7645: The Keying and Authentication for Routing Protocol (KARP) IS-IS Security Analysis

    Informational
  • RFC 7602: IS-IS Extended Sequence Number TLV

    Proposed Standard
  • RFC 7370: Updates to the IS-IS TLV Codepoints Registry

    Proposed Standard
  • Proposed Standard
  • Proposed Standard
  • Proposed Standard

    Obsoleted by RFC 7780

  • RFC 7142: Reclassification of RFC 1142 to Historic

    Informational
  • RFC 6822: IS-IS Multi-Instance

    Proposed Standard

    Obsoleted by RFC 8202

  • RFC 6823: Advertising Generic Information in IS-IS

    Proposed Standard
  • RFC 6571: Loop-Free Alternate (LFA) Applicability in Service Provider (SP) Networks

    Informational
  • RFC 6329: IS-IS Extensions Supporting IEEE 802.1aq Shortest Path Bridging

    Proposed Standard
  • Proposed Standard

    Obsoleted by RFC 7176

  • RFC 6232: Purge Originator Identification TLV for IS-IS

    Proposed Standard
  • RFC 6233: IS-IS Registry Extension for Purges

    Proposed Standard
  • RFC 6213: IS-IS BFD-Enabled TLV

    Proposed Standard
  • RFC 6165: Extensions to IS-IS for Layer-2 Systems

    Proposed Standard
  • RFC 6119: IPv6 Traffic Engineering in IS-IS

    Proposed Standard
  • RFC 5310: IS-IS Generic Cryptographic Authentication

    Proposed Standard
  • Proposed Standard
  • RFC 5392: OSPF Extensions in Support of Inter-Autonomous System (AS) MPLS and GMPLS Traffic Engineering

    Proposed Standard
  • RFC 5316: ISIS Extensions in Support of Inter-Autonomous System (AS) MPLS and GMPLS Traffic Engineering

    Proposed Standard

    Obsoleted by RFC 9346

  • RFC 5301: Dynamic Hostname Exchange Mechanism for IS-IS

    Proposed Standard
  • RFC 5302: Domain-Wide Prefix Distribution with Two-Level IS-IS

    Proposed Standard
  • RFC 5303: Three-Way Handshake for IS-IS Point-to-Point Adjacencies

    Proposed Standard
  • RFC 5304: IS-IS Cryptographic Authentication

    Proposed Standard
  • RFC 5305: IS-IS Extensions for Traffic Engineering

    Proposed Standard
  • RFC 5306: Restart Signaling for IS-IS

    Proposed Standard

    Obsoleted by RFC 8706

  • RFC 5307: IS-IS Extensions in Support of Generalized Multi-Protocol Label Switching (GMPLS)

    Proposed Standard
  • RFC 5308: Routing IPv6 with IS-IS

    Proposed Standard
  • Informational
  • RFC 5130: A Policy Control Mechanism in IS-IS Using Administrative Tags

    Proposed Standard
  • RFC 5120: M-ISIS: Multi Topology (MT) Routing in Intermediate System to Intermediate Systems (IS-ISs)

    Proposed Standard
  • RFC 5089: IS-IS Protocol Extensions for Path Computation Element (PCE) Discovery

    Proposed Standard
  • Proposed Standard
  • RFC 4971: Intermediate System to Intermediate System (IS-IS) Extensions for Advertising Router Information

    Proposed Standard

    Obsoleted by RFC 7981

  • RFC 4972: Routing Extensions for Discovery of Multiprotocol (MPLS) Label Switch Router (LSR) Traffic Engineering (TE) Mesh Membership

    Proposed Standard
  • RFC 4444: Management Information Base for Intermediate System to Intermediate System (IS-IS)

    Proposed Standard
  • RFC 4205: Intermediate System to Intermediate System (IS-IS) Extensions in Support of Generalized Multi-Protocol Label Switching (GMPLS)

    Informational

    Obsoleted by RFC 5307

  • RFC 3847: Restart Signaling for Intermediate System to Intermediate System (IS-IS)

    Informational

    Obsoleted by RFC 5306

  • RFC 3784: Intermediate System to Intermediate System (IS-IS) Extensions for Traffic Engineering (TE)

    Informational

    Obsoleted by RFC 5305

  • Informational

    Obsoleted by RFC 5311

  • RFC 3787: Recommendations for Interoperable IP Networks using Intermediate System to Intermediate System (IS-IS)

    Informational
  • RFC 3719: Recommendations for Interoperable Networks using Intermediate System to Intermediate System (IS-IS)

    Informational
  • RFC 3567: Intermediate System to Intermediate System (IS-IS) Cryptographic Authentication

    Informational

    Obsoleted by RFC 5304

  • RFC 3563: Cooperative Agreement Between the ISOC/IETF and ISO/IEC Joint Technical Committee 1/Sub Committee 6 (JTC1/SC6) on IS-IS Routing Protocol Development

    Informational
  • RFC 3373: Three-Way Handshake for Intermediate System to Intermediate System (IS-IS) Point-to-Point Adjacencies

    Informational

    Obsoleted by RFC 5303

  • RFC 3358: Optional Checksums in Intermediate System to Intermediate System (ISIS)

    Informational
  • RFC 3359: Reserved Type, Length and Value (TLV) Codepoints in Intermediate System to Intermediate System

    Informational
  • RFC 3277: Intermediate System to Intermediate System (IS-IS) Transient Blackhole Avoidance

    Informational
  • RFC 2966: Domain-wide Prefix Distribution with Two-Level IS-IS

    Informational

    Obsoleted by RFC 5302

  • RFC 2973: IS-IS Mesh Groups

    Informational
  • RFC 2763: Dynamic Hostname Exchange Mechanism for IS-IS

    Informational

    Obsoleted by RFC 5301

  • RFC 1195: Use of OSI IS-IS for routing in TCP/IP and dual environments

    Proposed Standard
  • RFC 1142: OSI IS-IS Intra-domain Routing Protocol

    Historic

    Obsoleted by RFC 7142

Subscribe to IS-IS

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.