IKE

IKE (Internet Key Exchange)

IKE subjects:

IKE RFCs (95)

Display RFCs as
  • RFC 9827: Renaming the Extended Sequence Numbers (ESN) Transform Type in the Internet Key Exchange Protocol Version 2 (IKEv2)

    Proposed Standard
  • RFC 9838: Group Key Management Using the Internet Key Exchange Protocol Version 2 (IKEv2)

    Proposed Standard
  • RFC 9867: Mixing Preshared Keys in the IKE_INTERMEDIATE and CREATE_CHILD_SA Exchanges of the Internet Key Exchange Protocol Version 2 (IKEv2) for Post-Quantum Security

    Proposed Standard
  • RFC 9593: Announcing Supported Authentication Methods in the Internet Key Exchange Protocol Version 2 (IKEv2)

    Proposed Standard
  • RFC 9611: Internet Key Exchange Protocol Version 2 (IKEv2) Support for Per-Resource Child Security Associations (SAs)

    Proposed Standard
  • RFC 9464: Internet Key Exchange Protocol Version 2 (IKEv2) Configuration for Encrypted DNS

    Proposed Standard
  • RFC 9478: Labeled IPsec Traffic Selector Support for the Internet Key Exchange Protocol Version 2 (IKEv2)

    Proposed Standard
  • RFC 9370: Multiple Key Exchanges in the Internet Key Exchange Protocol Version 2 (IKEv2)

    Proposed Standard
  • RFC 9385: Using GOST Cryptographic Algorithms in the Internet Key Exchange Protocol Version 2 (IKEv2)

    Informational
  • RFC 9395: Deprecation of the Internet Key Exchange Version 1 (IKEv1) Protocol and Obsoleted Algorithms

    Proposed Standard
  • RFC 9329: TCP Encapsulation of Internet Key Exchange Protocol (IKE) and IPsec Packets

    Proposed Standard
  • RFC 9242: Intermediate Exchange in the Internet Key Exchange Protocol Version 2 (IKEv2)

    Proposed Standard
  • RFC 9227: Using GOST Ciphers in the Encapsulating Security Payload (ESP) and Internet Key Exchange Version 2 (IKEv2) Protocols

    Informational
  • RFC 8983: Internet Key Exchange Protocol Version 2 (IKEv2) Notification Status Types for IPv4/IPv6 Coexistence

    Proposed Standard
  • RFC 8784: Mixing Preshared Keys in the Internet Key Exchange Protocol Version 2 (IKEv2) for Post-quantum Security

    Proposed Standard
  • RFC 8750: Implicit Initialization Vector (IV) for Counter-Based Ciphers in Encapsulating Security Payload (ESP)

    Proposed Standard
  • RFC 8598: Split DNS Configuration for the Internet Key Exchange Protocol Version 2 (IKEv2)

    Proposed Standard
  • RFC 8420: Using the Edwards-Curve Digital Signature Algorithm (EdDSA) in the Internet Key Exchange Protocol Version 2 (IKEv2)

    Proposed Standard
  • RFC 8423: Reclassification of Suite B Documents to Historic Status

    Informational
  • RFC 8221: Cryptographic Algorithm Implementation Requirements and Usage Guidance for Encapsulating Security Payload (ESP) and Authentication Header (AH)

    Proposed Standard
  • RFC 8247: Algorithm Implementation Requirements and Usage Guidance for the Internet Key Exchange Protocol Version 2 (IKEv2)

    Proposed Standard
  • RFC 8229: TCP Encapsulation of IKE and IPsec Packets

    Proposed Standard

    Obsoleted by RFC 9329

  • RFC 8031: Curve25519 and Curve448 for the Internet Key Exchange Protocol Version 2 (IKEv2) Key Agreement

    Proposed Standard
  • RFC 8019: Protecting Internet Key Exchange Protocol Version 2 (IKEv2) Implementations from Distributed Denial-of-Service Attacks

    Proposed Standard
  • RFC 7836: Guidelines on the Cryptographic Algorithms to Accompany the Usage of Standards GOST R 34.10-2012 and GOST R 34.11-2012

    Informational
  • RFC 7815: Minimal Internet Key Exchange Version 2 (IKEv2) Initiator Implementation

    Informational
  • RFC 7670: Generic Raw Public-Key Support for IKEv2

    Proposed Standard
  • RFC 7717: IKEv2-Derived Shared Secret Key for the One-Way Active Measurement Protocol (OWAMP) and Two-Way Active Measurement Protocol (TWAMP)

    Proposed Standard
  • RFC 7651: 3GPP IP Multimedia Subsystems (IMS) Option for the Internet Key Exchange Protocol Version 2 (IKEv2)

    Informational
  • RFC 7619: The NULL Authentication Method in the Internet Key Exchange Protocol Version 2 (IKEv2)

    Proposed Standard
  • RFC 7634: ChaCha20, Poly1305, and Their Use in the Internet Key Exchange Protocol (IKE) and IPsec

    Proposed Standard
  • RFC 7427: Signature Authentication in the Internet Key Exchange Version 2 (IKEv2)

    Proposed Standard
  • RFC 7383: Internet Key Exchange Protocol Version 2 (IKEv2) Message Fragmentation

    Proposed Standard
  • RFC 7296: STD 79: Internet Key Exchange Protocol Version 2 (IKEv2)

    Internet Standard
  • RFC 7018: Auto-Discovery VPN Problem Statement and Requirements

    Informational
  • RFC 6954: Using the Elliptic Curve Cryptography (ECC) Brainpool Curves for the Internet Key Exchange Protocol Version 2 (IKEv2)

    Informational
  • RFC 6989: Additional Diffie-Hellman Tests for the Internet Key Exchange Protocol Version 2 (IKEv2)

    Proposed Standard
  • RFC 6932: Brainpool Elliptic Curves for the Internet Key Exchange (IKE) Group Description Registry

    Informational
  • RFC 6867: An Internet Key Exchange Protocol Version 2 (IKEv2) Extension to Support EAP Re-authentication Protocol (ERP)

    Experimental
  • RFC 6738: Diameter IKEv2 SK: Using Shared Keys to Support Interaction between IKEv2 Servers and Diameter Servers

    Proposed Standard
  • RFC 6631: Password Authenticated Connection Establishment with the Internet Key Exchange Protocol version 2 (IKEv2)

    Experimental
  • RFC 6617: Secure Pre-Shared Key (PSK) Authentication for the Internet Key Exchange Protocol (IKE)

    Experimental
  • RFC 6628: Efficient Augmented Password-Only Authentication and Key Exchange for IKEv2

    Experimental
  • RFC 6467: Secure Password Framework for Internet Key Exchange Version 2 (IKEv2)

    Informational
  • RFC 6379: Suite B Cryptographic Suites for IPsec

    Historic
  • RFC 6311: Protocol Support for High Availability of IKEv2/IPsec

    Proposed Standard
  • RFC 6290: A Quick Crash Detection Method for the Internet Key Exchange Protocol (IKE)

    Proposed Standard
  • RFC 6193: Media Description for the Internet Key Exchange Protocol (IKE) in the Session Description Protocol (SDP)

    Informational
  • RFC 6071: IP Security (IPsec) and Internet Key Exchange (IKE) Document Roadmap

    Informational
  • RFC 6027: IPsec Cluster Problem Statement

    Informational
  • RFC 6023: A Childless Initiation of the Internet Key Exchange Version 2 (IKEv2) Security Association (SA)

    Experimental
  • RFC 5998: An Extension for EAP-Only Authentication in IKEv2

    Proposed Standard
  • RFC 5996: Internet Key Exchange Protocol Version 2 (IKEv2)

    Proposed Standard

    Obsoleted by RFC 7296

  • RFC 5930: Using Advanced Encryption Standard Counter Mode (AES-CTR) with the Internet Key Exchange version 02 (IKEv2) Protocol

    Informational
  • RFC 5903: Elliptic Curve Groups modulo a Prime (ECP Groups) for IKE and IKEv2

    Informational
  • RFC 5857: IKEv2 Extensions to Support Robust Header Compression over IPsec

    Proposed Standard
  • RFC 5739: IPv6 Configuration in Internet Key Exchange Protocol Version 2 (IKEv2)

    Experimental
  • RFC 5723: Internet Key Exchange Protocol Version 2 (IKEv2) Session Resumption

    Proposed Standard
  • RFC 5685: Redirect Mechanism for the Internet Key Exchange Protocol Version 2 (IKEv2)

    Proposed Standard
  • RFC 5386: Better-Than-Nothing Security: An Unauthenticated Mode of IPsec

    Proposed Standard
  • RFC 5282: Using Authenticated Encryption Algorithms with the Encrypted Payload of the Internet Key Exchange version 2 (IKEv2) Protocol

    Proposed Standard
  • RFC 5106: The Extensible Authentication Protocol-Internet Key Exchange Protocol version 2 (EAP-IKEv2) Method

    Experimental
  • RFC 5114: Additional Diffie-Hellman Groups for Use with IETF Standards

    Informational
  • RFC 4945: The Internet IP Security PKI Profile of IKEv1/ISAKMP, IKEv2, and PKIX

    Proposed Standard
  • RFC 4894: Use of Hash Algorithms in Internet Key Exchange (IKE) and IPsec

    Informational
  • RFC 4869: Suite B Cryptographic Suites for IPsec

    Historic

    Obsoleted by RFC 6379

  • RFC 4877: Mobile IPv6 Operation with IKEv2 and the Revised IPsec Architecture

    Proposed Standard
  • RFC 4806: Online Certificate Status Protocol (OCSP) Extensions to IKEv2

    Proposed Standard
  • RFC 4753: ECP Groups For IKE and IKEv2

    Informational

    Obsoleted by RFC 5903

  • RFC 4754: IKE and IKEv2 Authentication Using the Elliptic Curve Digital Signature Algorithm (ECDSA)

    Proposed Standard
  • RFC 4739: Multiple Authentication Exchanges in the Internet Key Exchange (IKEv2) Protocol

    Experimental
  • RFC 4718: IKEv2 Clarifications and Implementation Guidelines

    Informational

    Obsoleted by RFC 5996

  • RFC 4615: The Advanced Encryption Standard-Cipher-based Message Authentication Code-Pseudo-Random Function-128 (AES-CMAC-PRF-128) Algorithm for the Internet Key Exchange Protocol (IKE)

    Proposed Standard
  • RFC 4595: Use of IKEv2 in the Fibre Channel Security Association Management Protocol

    Informational
  • RFC 4478: Repeated Authentication in Internet Key Exchange (IKEv2) Protocol

    Experimental
  • RFC 4434: The AES-XCBC-PRF-128 Algorithm for the Internet Key Exchange Protocol (IKE)

    Proposed Standard
  • RFC 4322: Opportunistic Encryption using the Internet Key Exchange (IKE)

    Informational
  • RFC 4301: Security Architecture for the Internet Protocol

    Proposed Standard
  • RFC 4302: IP Authentication Header

    Proposed Standard
  • RFC 4303: IP Encapsulating Security Payload (ESP)

    Proposed Standard
  • RFC 4304: Extended Sequence Number (ESN) Addendum to IPsec Domain of Interpretation (DOI) for Internet Security Association and Key Management Protocol (ISAKMP)

    Proposed Standard
  • RFC 4306: Internet Key Exchange (IKEv2) Protocol

    Proposed Standard

    Obsoleted by RFC 5996

  • RFC 4307: Cryptographic Algorithms for Use in the Internet Key Exchange Version 2 (IKEv2)

    Proposed Standard

    Obsoleted by RFC 8247

  • RFC 4308: Cryptographic Suites for IPsec

    Proposed Standard
  • RFC 4109: Algorithms for Internet Key Exchange version 1 (IKEv1)

    Proposed Standard
  • RFC 3947: Negotiation of NAT-Traversal in the IKE

    Proposed Standard
  • RFC 3706: A Traffic-Based Method of Detecting Dead Internet Key Exchange (IKE) Peers

    Informational
  • RFC 3664: The AES-XCBC-PRF-128 Algorithm for the Internet Key Exchange Protocol (IKE)

    Proposed Standard

    Obsoleted by RFC 4434

  • RFC 3585: IPsec Configuration Policy Information Model

    Proposed Standard
  • RFC 3554: On the Use of Stream Control Transmission Protocol (SCTP) with IPsec

    Proposed Standard
  • RFC 3526: More Modular Exponential (MODP) Diffie-Hellman groups for Internet Key Exchange (IKE)

    Proposed Standard
  • RFC 2407: The Internet IP Security Domain of Interpretation for ISAKMP

    Historic

    Obsoleted by RFC 4306

  • RFC 2408: Internet Security Association and Key Management Protocol (ISAKMP)

    Historic

    Obsoleted by RFC 4306

  • RFC 2409: The Internet Key Exchange (IKE)

    Historic

    Obsoleted by RFC 4306

  • RFC 2412: The OAKLEY Key Determination Protocol

    Informational

Subscribe to IKE

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.