RTP

RTP (Real-time Transport Protocol)

RTP subjects:

RTP RFCs (87)

Display RFCs as
  • RFC 9626: Video Frame Marking RTP Header Extension

    Experimental
  • RFC 9429: JavaScript Session Establishment Protocol (JSEP)

    Proposed Standard
  • RFC 9443: Multiplexing Scheme Updates for QUIC

    Proposed Standard
  • RFC 9143: Negotiating Media Multiplexing Using the Session Description Protocol (SDP)

    Proposed Standard
  • RFC 9071: RTP-Mixer Formatting of Multiparty Real-Time Text

    Proposed Standard
  • RFC 8829: JavaScript Session Establishment Protocol (JSEP)

    Proposed Standard

    Obsoleted by RFC 9429

  • RFC 8843: Negotiating Media Multiplexing Using the Session Description Protocol (SDP)

    Proposed Standard

    Obsoleted by RFC 9143

  • RFC 8852: RTP Stream Identifier Source Description (SDES)

    Proposed Standard
  • RFC 8853: Using Simulcast in Session Description Protocol (SDP) and RTP Sessions

    Proposed Standard
  • RFC 8854: WebRTC Forward Error Correction Requirements

    Proposed Standard
  • RFC 8834: Media Transport and Use of RTP in WebRTC

    Proposed Standard
  • RFC 8849: Mapping RTP Streams to Controlling Multiple Streams for Telepresence (CLUE) Media Captures

    Proposed Standard
  • RFC 8860: Sending Multiple Types of Media in a Single RTP Session

    Proposed Standard
  • RFC 8869: Evaluation Test Cases for Interactive Real-Time Media over Wireless Networks

    Informational
  • RFC 8872: Guidelines for Using the Multiplexing Features of RTP to Support Multiple Media Streams

    Informational
  • RFC 8699: Coupled Congestion Control for RTP Media

    Experimental
  • RFC 8593: Video Traffic Models for RTP Congestion Control Evaluations

    Informational
  • RFC 8382: Shared Bottleneck Detection for Coupled Congestion Control for RTP Media

    Experimental
  • RFC 8298: Self-Clocked Rate Adaptation for Multimedia

    Experimental
  • RFC 8285: A General Mechanism for RTP Header Extensions

    Proposed Standard
  • RFC 8082: Using Codec Control Messages in the RTP Audio-Visual Profile with Feedback with Layered Codecs

    Proposed Standard
  • RFC 8083: Multimedia Congestion Control: Circuit Breakers for Unicast RTP Sessions

    Proposed Standard
  • RFC 8095: Services Provided by IETF Transport Protocols and Congestion Control Mechanisms

    Informational
  • RFC 8108: Sending Multiple RTP Streams in a Single RTP Session

    Proposed Standard
  • RFC 8016: Mobility with Traversal Using Relays around NAT (TURN)

    Proposed Standard
  • RFC 7850: Registering Values of the SDP 'proto' Field for Transporting RTP Media over TCP under Various RTP Profiles

    Proposed Standard
  • RFC 7656: A Taxonomy of Semantics and Mechanisms for Real-Time Transport Protocol (RTP) Sources

    Informational
  • RFC 7657: Differentiated Services (Diffserv) and Real-Time Communication

    Informational
  • RFC 7667: RTP Topologies

    Informational
  • RFC 7604: Comparison of Different NAT Traversal Techniques for Media Controlled by the Real-Time Streaming Protocol (RTSP)

    Informational
  • RFC 7273: RTP Clock Source Signalling

    Proposed Standard
  • RFC 7198: Duplicating RTP Streams

    Proposed Standard
  • RFC 7160: Support for Multiple Clock Rates in an RTP Session

    Proposed Standard
  • RFC 7164: RTP and Leap Seconds

    Proposed Standard
  • Proposed Standard
  • RFC 6828: Content Splicing for RTP Sessions

    Informational
  • RFC 6792: Guidelines for Use of the RTP Monitoring Framework

    Informational
  • RFC 6679: Explicit Congestion Notification (ECN) for RTP over UDP

    Proposed Standard
  • RFC 6659: Considerations for Deploying the Rapid Acquisition of Multicast RTP Sessions (RAMS) Method

    Informational
  • RFC 6464: A Real-time Transport Protocol (RTP) Header Extension for Client-to-Mixer Audio Level Indication

    Proposed Standard
  • RFC 6465: A Real-time Transport Protocol (RTP) Header Extension for Mixer-to-Client Audio Level Indication

    Proposed Standard
  • RFC 6354: Forward-Shifted RTP Redundancy Payload Support

    Proposed Standard
  • RFC 6284: Port Mapping between Unicast and Multicast RTP Sessions

    Proposed Standard
  • RFC 6285: Unicast-Based Rapid Acquisition of Multicast RTP Sessions

    Proposed Standard
  • RFC 5761: Multiplexing RTP Data and Control Packets on a Single Port

    Proposed Standard
  • RFC 5762: RTP and the Datagram Congestion Control Protocol (DCCP)

    Proposed Standard
  • RFC 5576: Source-Specific Media Attributes in the Session Description Protocol (SDP)

    Proposed Standard
  • RFC 5450: Transmission Time Offsets in RTP Streams

    Proposed Standard
  • RFC 5484: Associating Time-Codes with RTP Streams

    Proposed Standard
  • RFC 5372: Payload Format for JPEG 2000 Video: Extensions for Scalability and Main Header Recovery

    Proposed Standard
  • RFC 5285: A General Mechanism for RTP Header Extensions

    Proposed Standard

    Obsoleted by RFC 8285

  • RFC 5225: RObust Header Compression Version 2 (ROHCv2): Profiles for RTP, UDP, IP, ESP and UDP-Lite

    Proposed Standard
  • RFC 5104: Codec Control Messages in the RTP Audio-Visual Profile with Feedback (AVPF)

    Proposed Standard
  • RFC 5117: RTP Topologies

    Informational

    Obsoleted by RFC 7667

  • RFC 4901: Protocol Extensions for Header Compression over MPLS

    Proposed Standard
  • RFC 4856: Media Type Registration of Payload Formats in the RTP Profile for Audio and Video Conferences

    Proposed Standard
  • RFC 4815: RObust Header Compression (ROHC): Corrections and Clarifications to RFC 3095

    Proposed Standard
  • RFC 4734: Definition of Events for Modem, Fax, and Text Telephony Signals

    Proposed Standard
  • RFC 4696: An Implementation Guide for RTP MIDI

    Informational
  • RFC 4598: Real-time Transport Protocol (RTP) Payload Format for Enhanced AC-3 (E-AC-3) Audio

    Proposed Standard
  • RFC 4424: Real-Time Transport Protocol (RTP) Payload Format for the Variable-Rate Multimode Wideband (VMR-WB) Extension Audio Codec

    Proposed Standard
  • Proposed Standard
  • RFC 4348: Real-Time Transport Protocol (RTP) Payload Format for the Variable-Rate Multimode Wideband (VMR-WB) Audio Codec

    Proposed Standard
  • RFC 4351: Real-Time Transport Protocol (RTP) Payload for Text Conversation Interleaved in an Audio Stream

    Historic
  • RFC 4170: BCP 110: Tunneling Multiplexed Compressed RTP (TCRTP)

    Best Current Practice
  • RFC 4247: Requirements for Header Compression over MPLS

    Informational
  • RFC 4102: Registration of the text/red MIME Sub-Type

    Proposed Standard
  • RFC 4019: RObust Header Compression (ROHC): Profiles for User Datagram Protocol (UDP) Lite

    Proposed Standard
  • RFC 3951: Internet Low Bit Rate Codec (iLBC)

    Experimental
  • RFC 3952: Real-time Transport Protocol (RTP) Payload Format for internet Low Bit Rate Codec (iLBC) Speech

    Experimental
  • Proposed Standard
  • RFC 3551: STD 65: RTP Profile for Audio and Video Conferences with Minimal Control

    Internet Standard
  • RFC 3409: Lower Layer Guidelines for Robust RTP/UDP/IP Header Compression

    Informational
  • RFC 3389: Real-time Transport Protocol (RTP) Payload for Comfort Noise (CN)

    Proposed Standard
  • RFC 3267: Real-Time Transport Protocol (RTP) Payload Format and File Storage Format for the Adaptive Multi-Rate (AMR) and Adaptive Multi-Rate Wideband (AMR-WB) Audio Codecs

    Proposed Standard

    Obsoleted by RFC 4867

  • Proposed Standard

    Obsoleted by RFC 4362

  • RFC 3243: RObust Header Compression (ROHC): Requirements and Assumptions for 0-byte IP/UDP/RTP Compression

    Informational
  • RFC 3257: Stream Control Transmission Protocol Applicability Statement

    Informational
  • RFC 3158: RTP Testing Strategies

    Informational
  • RFC 3095: RObust Header Compression (ROHC): Framework and four profiles: RTP, UDP, ESP, and uncompressed

    Proposed Standard
  • RFC 3096: Requirements for robust IP/UDP/RTP header compression

    Informational
  • RFC 3009: Registration of parityfec MIME types

    Proposed Standard

    Obsoleted by RFC 5109

  • RFC 2959: Real-Time Transport Protocol Management Information Base

    Proposed Standard
  • RFC 2762: Sampling of the Group Membership in RTP

    Experimental
  • Proposed Standard
  • RFC 2354: Options for Repair of Streaming Media

    Informational
  • RFC 1890: RTP Profile for Audio and Video Conferences with Minimal Control

    Proposed Standard

    Obsoleted by RFC 3551

Subscribe to RTP

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.