RSVP

RSVP (Resource Reservation Protocol)

RSVP RFCs (114)

Display RFCs as
  • RFC 9705: Refresh-Interval Independent RSVP Fast Reroute Facility Protection

    Proposed Standard
  • RFC 9059: Path Computation Element Communication Protocol (PCEP) Extensions for Associated Bidirectional Label Switched Paths (LSPs)

    Proposed Standard
  • RFC 8779: Path Computation Element Communication Protocol (PCEP) Extensions for GMPLS

    Proposed Standard
  • RFC 8796: RSVP-TE Summary Fast Reroute Extensions for Label Switched Path (LSP) Tunnels

    Proposed Standard
  • RFC 8625: Ethernet Traffic Parameters with Availability Information

    Proposed Standard
  • RFC 8577: Signaling RSVP-TE Tunnels on a Shared MPLS Forwarding Plane

    Proposed Standard
  • RFC 8537: Updates to the Fast Reroute Procedures for Co-routed Associated Bidirectional Label Switched Paths (LSPs)

    Proposed Standard
  • RFC 8424: Extensions to RSVP-TE for Label Switched Path (LSP) Ingress Fast Reroute (FRR) Protection

    Experimental
  • RFC 8426: Recommendations for RSVP-TE and Segment Routing (SR) Label Switched Path (LSP) Coexistence

    Informational
  • RFC 8390: RSVP-TE Path Diversity Using Exclude Route

    Proposed Standard
  • RFC 8400: Extensions to RSVP-TE for Label Switched Path (LSP) Egress Protection

    Proposed Standard
  • RFC 8370: Techniques to Improve the Scalability of RSVP-TE Deployments

    Proposed Standard
  • RFC 8271: Updates to the Resource Reservation Protocol for Fast Reroute of Traffic Engineering GMPLS Label Switched Paths (LSPs)

    Proposed Standard
  • RFC 8149: RSVP Extensions for Reoptimization of Loosely Routed Point-to-Multipoint Traffic Engineering Label Switched Paths (LSPs)

    Proposed Standard
  • RFC 8131: RSVP-TE Signaling Procedure for End-to-End GMPLS Restoration and Resource Sharing

    Informational
  • Proposed Standard
  • RFC 7963: RSVP-TE Extension for Additional Signal Types in G.709 Optical Transport Networks (OTNs)

    Informational
  • RFC 7898: Domain Subobjects for Resource Reservation Protocol - Traffic Engineering (RSVP-TE)

    Experimental
  • RFC 7792: RSVP-TE Signaling Extensions in Support of Flexi-Grid Dense Wavelength Division Multiplexing (DWDM) Networks

    Proposed Standard
  • RFC 7699: Generalized Labels for the Flexi-Grid in Lambda Switch Capable (LSC) Label Switching Routers

    Proposed Standard
  • RFC 7570: Label Switched Path (LSP) Attribute in the Explicit Route Object (ERO)

    Proposed Standard
  • RFC 7571: GMPLS RSVP-TE Extensions for Lock Instruct and Loopback

    Proposed Standard
  • RFC 7551: RSVP-TE Extensions for Associated Bidirectional Label Switched Paths (LSPs)

    Proposed Standard
  • RFC 7487: Configuration of Proactive Operations, Administration, and Maintenance (OAM) Functions for MPLS-Based Transport Networks Using RSVP-TE

    Proposed Standard
  • RFC 7439: Gap Analysis for Operating IPv6-Only MPLS Networks

    Informational
  • RFC 7417: Extensions to Generic Aggregate RSVP for IPv4 and IPv6 Reservations over Pre-Congestion Notification (PCN) Domains

    Experimental
  • RFC 7369: GMPLS RSVP-TE Extensions for Ethernet Operations, Administration, and Maintenance (OAM) Configuration

    Proposed Standard
  • RFC 7260: GMPLS RSVP-TE Extensions for Operations, Administration, and Maintenance (OAM) Configuration

    Proposed Standard
  • RFC 6882: Support for Resource Reservation Protocol Traffic Engineering (RSVP-TE) in Layer 3 Virtual Private Networks (L3VPNs)

    Experimental
  • RFC 6780: RSVP ASSOCIATION Object Extensions

    Proposed Standard
  • RFC 6689: Usage of the RSVP ASSOCIATION Object

    Informational
  • RFC 6510: Resource Reservation Protocol (RSVP) Message Formats for Label Switched Path (LSP) Attributes Objects

    Proposed Standard
  • RFC 6511: Non-Penultimate Hop Popping Behavior and Out-of-Band Mapping for RSVP-TE Label Switched Paths

    Proposed Standard
  • RFC 6517: Mandatory Features in a Layer 3 Multicast BGP/MPLS VPN Solution

    Informational
  • RFC 6401: RSVP Extensions for Admission Priority

    Proposed Standard
  • RFC 6411: Applicability of Keying Methods for RSVP Security

    Informational
  • RFC 6383: Advice on When It Is Safe to Start Sending Data on Label Switched Paths Established Using RSVP-TE

    Informational
  • RFC 6387: GMPLS Asymmetric Bandwidth Bidirectional Label Switched Paths (LSPs)

    Proposed Standard
  • RFC 5945: Resource Reservation Protocol (RSVP) Proxy Approaches

    Informational
  • RFC 5946: Resource Reservation Protocol (RSVP) Extensions for Path-Triggered RSVP Receiver Proxy

    Proposed Standard
  • RFC 6016: Support for the Resource Reservation Protocol (RSVP) in Layer 3 VPNs

    Proposed Standard
  • RFC 5824: Requirements for Supporting Customer Resource ReSerVation Protocol (RSVP) and RSVP Traffic Engineering (RSVP-TE) over a BGP/MPLS IP-VPN

    Informational
  • RFC 5852: RSVP-TE Signaling Extension for LSP Handover from the Management Plane to the Control Plane in a GMPLS-Enabled Transport Network

    Proposed Standard
  • RFC 5814: Label Switched Path (LSP) Dynamic Provisioning Performance Metrics in Generalized MPLS Networks

    Proposed Standard
  • RFC 5710: PathErr Message Triggered MPLS and GMPLS LSP Reroutes

    Proposed Standard
  • RFC 5711: Node Behavior upon Originating and Receiving Resource Reservation Protocol (RSVP) Path Error Messages

    Proposed Standard
  • RFC 5553: Resource Reservation Protocol (RSVP) Extensions for Path Key Support

    Proposed Standard
  • RFC 5495: Description of the Resource Reservation Protocol - Traffic-Engineered (RSVP-TE) Graceful Restart Procedures

    Informational
  • RFC 5467: GMPLS Asymmetric Bandwidth Bidirectional Label Switched Paths (LSPs)

    Experimental

    Obsoleted by RFC 6387

  • RFC 5420: Encoding of Attributes for MPLS LSP Establishment Using Resource Reservation Protocol Traffic Engineering (RSVP-TE)

    Proposed Standard
  • RFC 5284: User-Defined Errors for RSVP

    Proposed Standard
  • RFC 5151: Inter-Domain MPLS and GMPLS Traffic Engineering -- Resource Reservation Protocol-Traffic Engineering (RSVP-TE) Extensions

    Proposed Standard
  • RFC 5063: Extensions to GMPLS Resource Reservation Protocol (RSVP) Graceful Restart

    Proposed Standard
  • RFC 4974: Generalized MPLS (GMPLS) RSVP-TE Signaling Extensions in Support of Calls

    Proposed Standard
  • RFC 4883: Benchmarking Terminology for Resource Reservation Capable Routers

    Informational
  • RFC 4920: Crankback Signaling Extensions for MPLS and GMPLS RSVP-TE

    Proposed Standard
  • RFC 4875: Extensions to Resource Reservation Protocol - Traffic Engineering (RSVP-TE) for Point-to-Multipoint TE Label Switched Paths (LSPs)

    Proposed Standard
  • RFC 4872: RSVP-TE Extensions in Support of End-to-End Generalized Multi-Protocol Label Switching (GMPLS) Recovery

    Proposed Standard
  • RFC 4873: GMPLS Segment Recovery

    Proposed Standard
  • RFC 4860: Generic Aggregate Resource ReSerVation Protocol (RSVP) Reservations

    Proposed Standard
  • RFC 4859: Codepoint Registry for the Flags Field in the Resource Reservation Protocol-Traffic Engineering (RSVP-TE) Session Attribute Object

    Informational
  • RFC 4874: Exclude Routes - Extension to Resource ReserVation Protocol-Traffic Engineering (RSVP-TE)

    Proposed Standard
  • RFC 4804: Aggregation of Resource ReSerVation Protocol (RSVP) Reservations over MPLS TE/DS-TE Tunnels

    Proposed Standard
  • RFC 4783: GMPLS - Communication of Alarm Information

    Proposed Standard
  • RFC 4736: Reoptimization of Multiprotocol Label Switching (MPLS) Traffic Engineering (TE) Loosely Routed Label Switched Path (LSP)

    Informational
  • RFC 4558: Node-ID Based Resource Reservation Protocol (RSVP) Hello: A Clarification Statement

    Proposed Standard
  • RFC 4495: A Resource Reservation Protocol (RSVP) Extension for the Reduction of Bandwidth of a Reservation Flow

    Proposed Standard
  • RFC 4420: Encoding of Attributes for Multiprotocol Label Switching (MPLS) Label Switched Path (LSP) Establishment Using Resource ReserVation Protocol-Traffic Engineering (RSVP-TE)

    Proposed Standard

    Obsoleted by RFC 5420

  • RFC 4230: RSVP Security Properties

    Informational
  • RFC 4208: Generalized Multiprotocol Label Switching (GMPLS) User-Network Interface (UNI): Resource ReserVation Protocol-Traffic Engineering (RSVP-TE) Support for the Overlay Model

    Proposed Standard
  • RFC 4124: Protocol Extensions for Support of Diffserv-aware MPLS Traffic Engineering

    Proposed Standard
  • RFC 4090: Fast Reroute Extensions to RSVP-TE for LSP Tunnels

    Proposed Standard
  • RFC 4094: Analysis of Existing Quality-of-Service Signaling Protocols

    Informational
  • RFC 3936: BCP 96: Procedures for Modifying the Resource reSerVation Protocol (RSVP)

    Best Current Practice
  • RFC 3726: Requirements for Signaling Protocols

    Informational
  • RFC 3524: Mapping of Media Streams to Resource Reservation Flows

    Proposed Standard
  • RFC 3520: Session Authorization Policy Element

    Proposed Standard
  • RFC 3521: Framework for Session Set-up with Media Authorization

    Informational
  • RFC 3474: Documentation of IANA assignments for Generalized MultiProtocol Label Switching (GMPLS) Resource Reservation Protocol - Traffic Engineering (RSVP-TE) Usage and Extensions for Automatically Switched Optical Network (ASON)

    Informational
  • RFC 3476: Documentation of IANA Assignments for Label Distribution Protocol (LDP), Resource ReSerVation Protocol (RSVP), and Resource ReSerVation Protocol-Traffic Engineering (RSVP-TE) Extensions for Optical UNI Signaling

    Informational
  • RFC 3496: Protocol Extension for Support of Asynchronous Transfer Mode (ATM) Service Class-aware Multiprotocol Label Switching (MPLS) Traffic Engineering

    Informational
  • RFC 3468: The Multiprotocol Label Switching (MPLS) Working Group decision on MPLS signaling protocols

    Informational
  • RFC 3473: Generalized Multi-Protocol Label Switching (GMPLS) Signaling Resource ReserVation Protocol-Traffic Engineering (RSVP-TE) Extensions

    Proposed Standard
  • Proposed Standard
  • RFC 3209: RSVP-TE: Extensions to RSVP for LSP Tunnels

    Proposed Standard
  • RFC 3210: Applicability Statement for Extensions to RSVP for LSP-Tunnels

    Informational
  • RFC 3181: Signaled Preemption Priority Policy Element

    Proposed Standard
  • RFC 3182: Identity Representation for RSVP

    Proposed Standard
  • RFC 3175: Aggregation of RSVP for IPv4 and IPv6 Reservations

    Proposed Standard
  • RFC 2961: RSVP Refresh Overhead Reduction Extensions

    Proposed Standard
  • RFC 3097: RSVP Cryptographic Authentication -- Updated Message Type Value

    Proposed Standard
  • RFC 2996: Format of the RSVP DCLASS Object

    Proposed Standard
  • RFC 2997: Specification of the Null Service Type

    Proposed Standard
  • RFC 2872: Application and Sub Application Identity Policy Element for Use with RSVP

    Proposed Standard
  • RFC 2814: SBM (Subnet Bandwidth Manager): A Protocol for RSVP-based Admission Control over IEEE 802-style networks

    Proposed Standard
  • RFC 2745: RSVP Diagnostic Messages

    Proposed Standard
  • RFC 2746: RSVP Operation Over IP Tunnels

    Proposed Standard
  • RFC 2747: RSVP Cryptographic Authentication

    Proposed Standard
  • RFC 2749: COPS usage for RSVP

    Proposed Standard
  • RFC 2750: RSVP Extensions for Policy Control

    Proposed Standard
  • RFC 2751: Signaled Preemption Priority Policy Element

    Proposed Standard

    Obsoleted by RFC 3181

  • RFC 2752: Identity Representation for RSVP

    Proposed Standard

    Obsoleted by RFC 3182

  • RFC 2755: Security Negotiation for WebNFS

    Informational
  • RFC 2490: A Simulation Model for IP Multicast with RSVP

    Informational
  • RFC 2430: A Provider Architecture for Differentiated Services and Traffic Engineering (PASTE)

    Informational
  • RFC 2379: BCP 24: RSVP over ATM Implementation Guidelines

    Best Current Practice
  • RFC 2380: RSVP over ATM Implementation Requirements

    Proposed Standard
  • RFC 2382: A Framework for Integrated Services and RSVP over ATM

    Informational
  • RFC 2205: Resource ReSerVation Protocol (RSVP) -- Version 1 Functional Specification

    Proposed Standard
  • RFC 2206: RSVP Management Information Base using SMIv2

    Proposed Standard
  • RFC 2207: RSVP Extensions for IPSEC Data Flows

    Proposed Standard
  • RFC 2208: Resource ReSerVation Protocol (RSVP) -- Version 1 Applicability Statement Some Guidelines on Deployment

    Informational
  • RFC 2209: Resource ReSerVation Protocol (RSVP) -- Version 1 Message Processing Rules

    Informational
  • RFC 2210: The Use of RSVP with IETF Integrated Services

    Proposed Standard

Subscribe to RSVP

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.