URN

Uniform Resource Names and URN namespaces

URN RFCs (95)

Display RFCs as
  • RFC 9676: LEX: A Uniform Resource Name (URN) Namespace for Sources of Law

    Informational
  • RFC 9517: A URN Namespace for the Data Documentation Initiative (DDI)

    Informational
  • RFC 9278: JWK Thumbprint URI

    Proposed Standard
  • RFC 9039: Uniform Resource Names for Device Identifiers

    Proposed Standard
  • RFC 8515: URN Namespace for ETSI Documents

    Informational
  • RFC 8458: Using National Bibliography Numbers as Uniform Resource Names

    Informational
  • RFC 8464: A URN Namespace for Device Identity and Mobile Equipment Identity (MEID)

    Informational
  • RFC 8465: Using the Mobile Equipment Identity (MEID) URN as an Instance ID

    Informational
  • RFC 8433: A Simpler Method for Resolving Alert-Info URNs

    Informational
  • RFC 8254: Uniform Resource Name (URN) Namespace Registration Transition

    Proposed Standard
  • RFC 8141: Uniform Resource Names (URNs)

    Proposed Standard
  • RFC 8107: Advertising Digital Identifier (Ad-ID) URN Namespace Definition

    Informational
  • RFC 8069: URN Namespace for IEEE

    Informational
  • RFC 8057: Uniform Resource Name (URN) Namespaces for Broadband Forum

    Informational
  • RFC 7972: Entertainment Identifier Registry (EIDR) URN Namespace Definition

    Informational
  • RFC 7853: A URN Namespace for Globus

    Informational
  • RFC 7818: URN Namespace for MEF Documents

    Informational
  • RFC 7803: BCP 203: Changing the Registration Policy for the NETCONF Capability URNs Registry

    Best Current Practice
  • RFC 7738: A Uniform Resource Name (URN) Namespace for the Consultative Committee for Space Data Systems (CCSDS)

    Informational
  • RFC 7467: URN Namespace for the North Atlantic Treaty Organization (NATO)

    Informational
  • RFC 7528: A Uniform Resource Name (URN) Namespace for the Hybrid Broadcast Broadband TV (HbbTV) Association

    Informational
  • RFC 7462: URNs for the Alert-Info Header Field of the Session Initiation Protocol (SIP)

    Proposed Standard
  • RFC 7354: Update to the Registrant Information for the Digital Video Broadcasting Project (DVB) Uniform Resource Name (URN) Namespace

    Informational
  • RFC 7302: Entertainment Identifier Registry (EIDR) URN Namespace Definition

    Informational

      Obsoleted by RFC 7972

  • RFC 7254: A Uniform Resource Name Namespace for the Global System for Mobile Communications Association (GSMA) and the International Mobile station Equipment Identity (IMEI)

    Informational
  • RFC 7255: Using the International Mobile station Equipment Identity (IMEI) Uniform Resource Name (URN) as an Instance ID

    Informational
  • RFC 7207: A Uniform Resource Name (URN) Namespace for Eurosystem Messaging

    Informational
  • RFC 7163: URN for Country-Specific Emergency Services

    Proposed Standard
  • RFC 6963: BCP 183: A Uniform Resource Name (URN) Namespace for Examples

    Best Current Practice
  • RFC 6924: Registration of Second-Level URN Namespaces under "ietf"

    Informational
  • RFC 6893: A Uniform Resource Name (URN) Namespace for the Open IPTV Forum (OIPF)

    Informational
  • RFC 6755: An IETF URN Sub-Namespace for OAuth

    Informational
  • RFC 6588: A URN Namespace for ucode

    Informational
  • RFC 6453: A URN Namespace for the Open Grid Forum (OGF)

    Informational
  • RFC 6288: URN Namespace for the Defence Geospatial Information Working Group (DGIWG)

    Informational
  • RFC 6338: Definition of a Uniform Resource Name (URN) Namespace for the Schema for Academia (SCHAC)

    Informational
  • RFC 6289: A Uniform Resource Name (URN) Namespace for CableLabs

    Informational
  • RFC 6061: Uniform Resource Name (URN) Namespace for the National Emergency Number Association (NENA)

    Informational
  • RFC 5328: A Uniform Resource Name (URN) Namespace for the Digital Video Broadcasting Project (DVB)

    Informational
  • RFC 5279: A Uniform Resource Name (URN) Namespace for the 3rd Generation Partnership Project (3GPP)

    Informational
  • RFC 5174: A Uniform Resource Name (URN) Namespace for the European Broadcasting Union (EBU)

    Informational
  • RFC 5165: A Uniform Resource Name (URN) Namespace for the Open Geospatial Consortium (OGC)

    Informational
  • RFC 5141: A Uniform Resource Name (URN) Namespace for the International Organization for Standardization (ISO)

    Informational
  • RFC 5138: A Uniform Resource Name (URN) Namespace for the Commission for the Management and Application of Geoscience Information (CGI)

    Informational
  • RFC 5119: A Uniform Resource Name (URN) Namespace for the Society of Motion Picture and Television Engineers (SMPTE)

    Informational
  • Informational
  • RFC 5031: A Uniform Resource Name (URN) for Emergency and Other Well-Known Services

    Proposed Standard
  • RFC 4926: A URN Namespace for GEANT

    Informational
  • RFC 4854: A Uniform Resource Name (URN) Namespace for Extensions to the Extensible Messaging and Presence Protocol (XMPP)

    Informational
  • RFC 4729: A Uniform Resource Name (URN) Namespace for the Near Field Communication (NFC) Forum

    Informational
  • RFC 4688: A Uniform Resource Name (URN) Namespace for Aerospace and Defence Industries Association of Europe (ASD) Specification 1000D

    Informational
  • RFC 4617: A Uniform Resource Name (URN) Formal Namespace for the Latvian National Government Integration Project

    Informational
  • RFC 4246: International Standard Audiovisual Number (ISAN) URN Definition

    Informational
  • RFC 4350: A Uniform Resource Name (URN) Formal Namespace for the New Zealand Government

    Informational
  • RFC 4358: A Uniform Resource Name (URN) Namespace for the Open Mobile Alliance (OMA)

    Informational
  • RFC 4198: A Uniform Resource Name (URN) Namespace for Federated Content

    Informational
  • RFC 4179: Using Universal Content Identifier (UCI) as Uniform Resource Names (URN)

    Informational
  • RFC 4195: A Uniform Resource Name (URN) Namespace for the TV-Anytime Forum

    Informational
  • RFC 4152: A Uniform Resource Name (URN) Namespace for the Common Language Equipment Identifier (CLEI) Code

    Informational
  • RFC 4122: A Universally Unique IDentifier (UUID) URN Namespace

    Proposed Standard

      Obsoleted by RFC 9562

  • RFC 3937: A Uniform Resource Name (URN) Namespace for the International Press Telecommunications Council (IPTC)

    Informational
  • RFC 3622: A Uniform Resource Name (URN) Namespace for the Liberty Alliance Project

    Informational
  • RFC 3613: Definition of a Uniform Resource Name (URN) Namespace for the Middleware Architecture Committee for Education (MACE)

    Informational
  • RFC 3614: A Uniform Resource Name (URN) Namespace for the Motion Picture Experts Group (MPEG)

    Informational
  • RFC 3615: A Uniform Resource Name (URN) Namespace for SWIFT Financial Messaging

    Informational
  • RFC 3616: A Uniform Resource Name (URN) Namespace for Foundation for Intelligent Physical Agents (FIPA)

    Informational
  • RFC 3553: BCP 73: An IETF URN Sub-namespace for Registered Protocol Parameters

    Best Current Practice
  • RFC 3541: A Uniform Resource Name (URN) Namespace for the Web3D Consortium (Web3D)

    Informational
  • RFC 3401: Dynamic Delegation Discovery System (DDDS) Part One: The Comprehensive DDDS

    Informational
  • RFC 3402: Dynamic Delegation Discovery System (DDDS) Part Two: The Algorithm

    Proposed Standard
  • RFC 3403: Dynamic Delegation Discovery System (DDDS) Part Three: The Domain Name System (DNS) Database

    Proposed Standard
  • RFC 3404: Dynamic Delegation Discovery System (DDDS) Part Four: The Uniform Resource Identifiers (URI)

    Proposed Standard
  • RFC 3405: BCP 65: Dynamic Delegation Discovery System (DDDS) Part Five: URI.ARPA Assignment Procedures

    Best Current Practice
  • RFC 3406: Uniform Resource Names (URN) Namespace Definition Mechanisms

    Best Current Practice

      Obsoleted by RFC 8141

  • RFC 3305: Report from the Joint W3C/IETF URI Planning Interest Group: Uniform Resource Identifiers (URIs), URLs, and Uniform Resource Names (URNs): Clarifications and Recommendations

    Informational
  • RFC 3187: Using International Standard Book Numbers as Uniform Resource Names

    Historic

      Obsoleted by RFC 8254

  • RFC 3188: Using National Bibliography Numbers as Uniform Resource Names

    Informational

      Obsoleted by RFC 8458

  • RFC 3151: A URN Namespace for Public Identifiers

    Informational
  • RFC 3120: A URN Namespace for XML.org

    Informational
  • RFC 3121: A URN Namespace for OASIS

    Informational
  • RFC 3085: URN Namespace for NewsML Resources

    Informational
  • RFC 3061: A URN Namespace of Object Identifiers

    Informational
  • RFC 3043: The Network Solutions Personal Internet Name (PIN): A URN Namespace for People and Organizations

    Informational
  • RFC 3044: Using The ISSN (International Serial Standard Number) as URN (Uniform Resource Names) within an ISSN-URN Namespace

    Historic

      Obsoleted by RFC 8254

  • RFC 3001: A URN Namespace of Object Identifiers

    Informational

      Obsoleted by RFC 3061

  • RFC 2915: The Naming Authority Pointer (NAPTR) DNS Resource Record

    Proposed Standard

      Obsoleted by RFC 3401, RFC 3402, RFC 3403, RFC 3404

  • RFC 2648: A URN Namespace for IETF Documents

    Informational
  • RFC 2611: BCP 33: URN Namespace Definition Mechanisms

    Best Current Practice

      Obsoleted by RFC 3406

  • RFC 2483: URI Resolution Services Necessary for URN Resolution

    Experimental
  • RFC 2288: Using Existing Bibliographic Identifiers as Uniform Resource Names

    Informational
  • RFC 2276: Architectural Principles of Uniform Resource Name Resolution

    Informational
  • RFC 2168: Resolution of Uniform Resource Identifiers using the Domain Name System

    Experimental

      Obsoleted by RFC 3401, RFC 3402, RFC 3403, RFC 3404

  • RFC 2169: A Trivial Convention for using HTTP in URN Resolution

    Historic
  • RFC 2141: URN Syntax

    Proposed Standard

      Obsoleted by RFC 8141

  • RFC 1737: Functional Requirements for Uniform Resource Names

    Informational

Subscribe to URN

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.