tunneling

Tunneling: IP-in-IP encapsulation and generic tunnelling

tunneling subjects:

tunneling RFCs (98)

Display RFCs as
  • RFC 9599: BCP 89: Guidelines for Adding Congestion Notification to Protocols that Encapsulate IP

    Best Current Practice
  • RFC 9601: Propagating Explicit Congestion Notification across IP Tunnel Headers Separated by a Shim

    Proposed Standard
  • RFC 9572: Updates to EVPN Broadcast, Unknown Unicast, or Multicast (BUM) Procedures

    Proposed Standard
  • RFC 9573: MVPN/EVPN Tunnel Aggregation with Common Labels

    Proposed Standard
  • RFC 9458: Oblivious HTTP

    Proposed Standard
  • RFC 9464: Internet Key Exchange Protocol Version 2 (IKEv2) Configuration for Encrypted DNS

    Proposed Standard
  • RFC 9185: DTLS Tunnel between a Media Distributor and Key Distributor to Facilitate Key Exchange

    Informational
  • RFC 9188: Generic Multi-Access (GMA) Encapsulation Protocol

    Experimental
  • RFC 9012: The BGP Tunnel Encapsulation Attribute

    Proposed Standard
  • RFC 9013: OSPF Advertisement of Tunnel Encapsulations

    Proposed Standard
  • RFC 8892: Guidelines and Registration Procedures for Interface Types and Tunnel Types

    Proposed Standard
  • RFC 8796: RSVP-TE Summary Fast Reroute Extensions for Label Switched Path (LSP) Tunnels

    Proposed Standard
  • RFC 8776: Common YANG Data Types for Traffic Engineering

    Proposed Standard
  • RFC 8662: Entropy Label for Source Packet Routing in Networking (SPRING) Tunnels

    Proposed Standard
  • RFC 8687: OSPF Routing with Cross-Address Family Traffic Engineering Tunnels

    Proposed Standard
  • RFC 8675: A YANG Data Model for Tunnel Interface Types

    Proposed Standard
  • RFC 8577: Signaling RSVP-TE Tunnels on a Shared MPLS Forwarding Plane

    Proposed Standard
  • RFC 8502: L2L3 VPN Multicast MIB

    Proposed Standard
  • RFC 8503: BGP/MPLS Layer 3 VPN Multicast Management Information Base

    Proposed Standard
  • RFC 8084: BCP 208: Network Transport Circuit Breakers

    Best Current Practice
  • RFC 8016: Mobility with Traversal Using Relays around NAT (TURN)

    Proposed Standard
  • RFC 7988: Ingress Replication Tunnels in Multicast VPN

    Proposed Standard
  • Proposed Standard
  • RFC 7902: Registry and Extensions for P-Multicast Service Interface Tunnel Attribute Flags

    Proposed Standard
  • RFC 7740: Simulating Partial Mesh of Multipoint-to-Multipoint (MP2MP) Provider Tunnels with Ingress Replication

    Proposed Standard
  • RFC 7600: IPv4 Residual Deployment via IPv6 - A Stateless Solution (4rd)

    Experimental
  • RFC 7582: Multicast Virtual Private Network (MVPN): Using Bidirectional P-Tunnels

    Proposed Standard
  • RFC 7510: Encapsulating MPLS in UDP

    Proposed Standard
  • RFC 7385: IANA Registry for P-Multicast Service Interface (PMSI) Tunnel Type Code Points

    Proposed Standard
  • RFC 7359: Layer 3 Virtual Private Network (VPN) Tunnel Traffic Leakages in Dual-Stack Hosts/Networks

    Informational
  • RFC 7110: Return Path Specified Label Switched Path (LSP) Ping

    Proposed Standard
  • RFC 7059: A Comparison of IPv6-over-IPv4 Tunnel Mechanisms

    Informational
  • RFC 6964: Operational Guidance for IPv6 Deployment in IPv4 Sites Using the Intra-Site Automatic Tunnel Addressing Protocol (ISATAP)

    Informational
  • RFC 6935: IPv6 and UDP Checksums for Tunneled Packets

    Proposed Standard
  • RFC 6758: Tunneling of SMTP Message Transfer Priorities

    Informational
  • RFC 6751: Native IPv6 behind IPv4-to-IPv4 NAT Customer Premises Equipment (6a44)

    Experimental
  • RFC 6660: Encoding Three Pre-Congestion Notification (PCN) States in the IP Header Using a Single Diffserv Codepoint (DSCP)

    Proposed Standard
  • RFC 6424: Mechanism for Performing Label Switched Path Ping (LSP Ping) over MPLS Tunnels

    Proposed Standard

      Obsoleted by RFC 8029

  • Proposed Standard
  • RFC 6252: A Framework of Media-Independent Pre-Authentication (MPA) for Inter-Domain Handover Optimization

    Informational
  • RFC 6169: Security Concerns with IP Tunneling

    Informational
  • RFC 5979: NSIS Operation over IP Tunnels

    Experimental
  • RFC 6179: The Internet Routing Overlay Network (IRON)

    Experimental
  • RFC 6139: Routing and Addressing in Networks with Global Enterprise Recursion (RANGER) Scenarios

    Informational
  • RFC 6040: Tunnelling of Explicit Congestion Notification

    Proposed Standard
  • RFC 5579: Transmission of IPv4 Packets over Intra-Site Automatic Tunnel Addressing Protocol (ISATAP) Interfaces

    Informational
  • RFC 5558: Virtual Enterprise Traversal (VET)

    Informational
  • RFC 5320: The Subnetwork Encapsulation and Adaptation Layer (SEAL)

    Experimental
  • RFC 5619: Softwire Security Analysis and Requirements

    Proposed Standard
  • RFC 5566: BGP IPsec Tunnel Encapsulation Attribute

    Proposed Standard

      Obsoleted by RFC 9012

  • RFC 5512: The BGP Encapsulation Subsequent Address Family Identifier (SAFI) and the BGP Tunnel Encapsulation Attribute

    Proposed Standard

      Obsoleted by RFC 9012

  • RFC 5214: Intra-Site Automatic Tunnel Addressing Protocol (ISATAP)

    Informational
  • RFC 5129: Explicit Congestion Marking in MPLS

    Proposed Standard
  • RFC 4905: Encapsulation Methods for Transport of Layer 2 Frames over MPLS Networks

    Historic
  • RFC 4891: Using IPsec to Secure IPv6-in-IPv4 Tunnels

    Informational
  • RFC 4840: Multiple Encapsulation Methods Considered Harmful

    Informational
  • RFC 4817: Encapsulation of MPLS over Layer 2 Tunneling Protocol Version 3

    Proposed Standard
  • RFC 4804: Aggregation of Resource ReSerVation Protocol (RSVP) Reservations over MPLS TE/DS-TE Tunnels

    Proposed Standard
  • RFC 4651: A Taxonomy and Analysis of Enhancements to Mobile IPv6 Route Optimization

    Informational
  • RFC 4571: Framing Real-time Transport Protocol (RTP) and RTP Control Protocol (RTCP) Packets over Connection-Oriented Transport

    Proposed Standard
  • RFC 4459: MTU and Fragmentation Issues with In-the-Network Tunneling

    Informational
  • RFC 4254: The Secure Shell (SSH) Connection Protocol

    Proposed Standard
  • RFC 4282: The Network Access Identifier

    Proposed Standard

      Obsoleted by RFC 7542

  • RFC 4170: BCP 110: Tunneling Multiplexed Compressed RTP (TCRTP)

    Best Current Practice
  • RFC 4169: Hypertext Transfer Protocol (HTTP) Digest Authentication Using Authentication and Key Agreement (AKA) Version-2

    Informational
  • RFC 4214: Intra-Site Automatic Tunnel Addressing Protocol (ISATAP)

    Experimental

      Obsoleted by RFC 5214

  • RFC 4087: IP Tunnel MIB

    Proposed Standard
  • RFC 4090: Fast Reroute Extensions to RSVP-TE for LSP Tunnels

    Proposed Standard
  • RFC 3906: Calculating Interior Gateway Protocol (IGP) Routes Over Traffic Engineering Tunnels

    Informational
  • RFC 3620: The TUNNEL Profile

    Proposed Standard
  • RFC 3609: Tracing Requirements for Generic Tunnels

    Informational
  • RFC 3519: Mobile IP Traversal of Network Address Translation (NAT) Devices

    Proposed Standard
  • RFC 3456: Dynamic Host Configuration Protocol (DHCPv4) Configuration of IPsec Tunnel Mode

    Proposed Standard
  • RFC 3422: Forwarding Media Access Control (MAC) Frames over Multiple Access Protocol over Synchronous Optical Network/Synchronous Digital Hierarchy (MAPOS)

    Informational
  • RFC 3378: EtherIP: Tunneling Ethernet Frames in IP Datagrams

    Informational
  • RFC 3186: MAPOS/PPP Tunneling mode

    Informational
  • RFC 3209: RSVP-TE: Extensions to RSVP for LSP Tunnels

    Proposed Standard
  • RFC 3210: Applicability Statement for Extensions to RSVP for LSP-Tunnels

    Informational
  • Proposed Standard
  • RFC 3024: Reverse Tunneling for Mobile IP, revised

    Proposed Standard
  • RFC 2983: Differentiated Services and Tunnels

    Informational
  • RFC 2867: RADIUS Accounting Modifications for Tunnel Protocol Support

    Informational
  • RFC 2868: RADIUS Attributes for Tunnel Protocol Support

    Informational
  • RFC 2746: RSVP Operation Over IP Tunnels

    Proposed Standard
  • RFC 2709: Security Model with Tunnel-mode IPsec for NAT Domains

    Informational
  • RFC 2667: IP Tunnel MIB

    Proposed Standard

      Obsoleted by RFC 4087

  • RFC 2637: Point-to-Point Tunneling Protocol (PPTP)

    Informational
  • RFC 2529: Transmission of IPv6 over IPv4 Domains without Explicit Tunnels

    Proposed Standard
  • RFC 2486: The Network Access Identifier

    Proposed Standard

      Obsoleted by RFC 4282

  • RFC 2473: Generic Packet Tunneling in IPv6 Specification

    Proposed Standard
  • RFC 2442: The Batch SMTP Media Type

    Informational
  • RFC 2341: Cisco Layer Two Forwarding (Protocol) "L2F"

    Historic
  • RFC 2344: Reverse Tunneling for Mobile IP

    Proposed Standard

      Obsoleted by RFC 3024

  • RFC 2107: Ascend Tunnel Management Protocol - ATMP

    Informational
  • RFC 1326: Mutual Encapsulation Considered Dangerous

    Informational
  • RFC 1241: Scheme for an internet encapsulation protocol: Version 1

    Experimental
  • RFC 1234: Tunneling IPX traffic through IP networks

    Historic
  • RFC 893: Trailer encapsulations

    Unknown

Subscribe to tunneling

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.