IMAP

IMAP (Internet Message Access Protocol)

IMAP RFCs (114)

Display RFCs as
  • RFC 10022: IMAP UIDBATCHES Extension

    Proposed Standard
  • RFC 9979: Registration of Further IMAP/JMAP Keywords and Mailbox Name Attributes

    Informational
  • RFC 9755: IMAP Support for UTF-8

    Proposed Standard
  • RFC 9738: IMAP MESSAGELIMIT Extension

    Experimental
  • RFC 9698: The JMAPACCESS Extension for IMAP

    Proposed Standard
  • RFC 9671: Sieve Email Filtering: Extension for Processing Calendar Attachments

    Proposed Standard
  • RFC 9585: IMAP Response Code for Command Progress Notifications

    Proposed Standard
  • RFC 9590: IMAP Extension for Returning Mailbox METADATA in Extended LIS

    Proposed Standard
  • RFC 9586: IMAP Extension for Using and Returning Unique Identifiers (UIDs) Only

    Experimental
  • RFC 9122: IANA Registry for Sieve Actions

    Proposed Standard
  • RFC 9394: IMAP PARTIAL Extension for Paged SEARCH and FETCH

    Proposed Standard
  • RFC 9208: IMAP QUOTA Extension

    Proposed Standard
  • RFC 9051: Internet Message Access Protocol (IMAP) - Version 4rev2

    Proposed Standard
  • RFC 9042: Sieve Email Filtering: Delivery by MAILBOXID

    Proposed Standard
  • RFC 8970: IMAP4 Extension: Message Preview Generation

    Proposed Standard
  • RFC 8579: Sieve Email Filtering: Delivering to Special-Use Mailboxes

    Proposed Standard
  • RFC 8580: Sieve Extension: File Carbon Copy (FCC)

    Proposed Standard
  • RFC 8508: IMAP REPLACE Extension

    Proposed Standard
  • RFC 8514: Internet Message Access Protocol (IMAP) - SAVEDATE Extension

    Proposed Standard
  • RFC 8474: IMAP Extension for Object Identifiers

    Proposed Standard
  • RFC 8457: IMAP "$Important" Keyword and "\Important" Special-Use Attribute

    Proposed Standard
  • RFC 8437: IMAP UNAUTHENTICATE Extension for Connection Reuse

    Proposed Standard
  • RFC 8438: IMAP Extension for STATUS=SIZE

    Proposed Standard
  • RFC 8440: IMAP4 Extension for Returning MYRIGHTS Information in Extended LIST

    Proposed Standard
  • RFC 8314: Cleartext Considered Obsolete: Use of Transport Layer Security (TLS) for Email Submission and Access

    Proposed Standard
  • RFC 7888: IMAP4 Non-synchronizing Literals

    Proposed Standard
  • RFC 7889: The IMAP APPENDLIMIT Extension

    Proposed Standard
  • Proposed Standard
  • RFC 7377: IMAP4 Multimailbox SEARCH Extension

    Proposed Standard
  • RFC 7162: IMAP Extensions: Quick Flag Changes Resynchronization (CONDSTORE) and Quick Mailbox Resynchronization (QRESYNC)

    Proposed Standard
  • RFC 7017: IMAP Access to IETF Email List Archives

    Informational
  • RFC 6855: IMAP Support for UTF-8

    Proposed Standard

    Obsoleted by RFC 9755

  • RFC 6858: Simplified POP and IMAP Downgrading for Internationalized Email

    Proposed Standard
  • RFC 6851: Internet Message Access Protocol (IMAP) - MOVE Extension

    Proposed Standard
  • RFC 6785: Support for Internet Message Access Protocol (IMAP) Events in Sieve

    Proposed Standard
  • RFC 6237: IMAP4 Multimailbox SEARCH Extension

    Experimental

    Obsoleted by RFC 7377

  • RFC 6186: Use of SRV Records for Locating Email Submission/Access Services

    Proposed Standard
  • Proposed Standard
  • RFC 6154: IMAP LIST Extension for Special-Use Mailboxes

    Proposed Standard
  • RFC 5957: Display-Based Address Sorting for the IMAP4 SORT Extension

    Proposed Standard
  • RFC 5788: IMAP4 Keyword Registry

    Proposed Standard
  • RFC 5819: IMAP4 Extension for Returning STATUS Information in Extended LIST

    Proposed Standard
  • RFC 5738: IMAP Support for UTF-8

    Experimental

    Obsoleted by RFC 6855

  • RFC 5616: Streaming Internet Messaging Attachments

    Informational
  • RFC 5550: The Internet Email to Support Diverse Service Environments (Lemonade) Profile

    Proposed Standard
  • RFC 5551: Lemonade Notifications Architecture

    Informational
  • RFC 5593: Internet Message Access Protocol (IMAP) - URL Access Identifier Extension

    Proposed Standard
  • RFC 5524: Extended URLFETCH for Binary and Converted Parts

    Proposed Standard
  • RFC 5530: IMAP Response Codes

    Proposed Standard
  • RFC 5423: Internet Message Store Events

    Proposed Standard
  • RFC 5442: LEMONADE Architecture - Supporting Open Mobile Alliance (OMA) Mobile Email (MEM) Using Internet Mail

    Informational
  • RFC 5465: The IMAP NOTIFY Extension

    Proposed Standard
  • RFC 5466: IMAP4 Extension for Named Searches (Filters)

    Proposed Standard
  • RFC 5464: The IMAP METADATA Extension

    Proposed Standard
  • RFC 5383: BCP 143: Deployment Considerations for Lemonade-Compliant Mobile Email

    Best Current Practice
  • RFC 5267: Contexts for IMAP4

    Proposed Standard
  • RFC 5259: Internet Message Access Protocol - CONVERT Extension

    Proposed Standard
  • RFC 5257: Internet Message Access Protocol - ANNOTATE Extension

    Experimental
  • RFC 5255: Internet Message Access Protocol Internationalization

    Proposed Standard
  • RFC 5256: Internet Message Access Protocol - SORT and THREAD Extensions

    Proposed Standard
  • RFC 5258: Internet Message Access Protocol version 4 - LIST Command Extensions

    Proposed Standard
  • RFC 5182: IMAP Extension for Referencing the Last SEARCH Result

    Proposed Standard
  • RFC 5161: The IMAP ENABLE Extension

    Proposed Standard
  • RFC 5162: IMAP4 Extensions for Quick Mailbox Resynchronization

    Proposed Standard

    Obsoleted by RFC 7162

  • RFC 5232: Sieve Email Filtering: Imap4flags Extension

    Proposed Standard
  • RFC 5092: IMAP URL Scheme

    Proposed Standard
  • RFC 4959: IMAP Extension for Simple Authentication and Security Layer (SASL) Initial Client Response

    Proposed Standard
  • RFC 5032: WITHIN Search Extension to the IMAP Protocol

    Proposed Standard
  • RFC 4978: The IMAP COMPRESS Extension

    Proposed Standard
  • RFC 4731: IMAP4 Extension to SEARCH Command for Controlling What Kind of Information Is Returned

    Proposed Standard
  • RFC 4549: Synchronization Operations for Disconnected IMAP4 Clients

    Informational
  • RFC 4550: Internet Email to Support Diverse Service Environments (Lemonade) Profile

    Proposed Standard

    Obsoleted by RFC 5550

  • RFC 4551: IMAP Extension for Conditional STORE Operation or Quick Flag Changes Resynchronization

    Proposed Standard

    Obsoleted by RFC 7162

  • RFC 4467: Internet Message Access Protocol (IMAP) - URLAUTH Extension

    Proposed Standard
  • RFC 4468: Message Submission BURL Extension

    Proposed Standard
  • RFC 4469: Internet Message Access Protocol (IMAP) CATENATE Extension

    Proposed Standard
  • RFC 4466: Collected Extensions to IMAP4 ABNF

    Proposed Standard
  • RFC 4416: Goals for Internet Messaging to Support Diverse Service Environments

    Informational
  • RFC 4356: Mapping Between the Multimedia Messaging Service (MMS) and Internet Mail

    Proposed Standard
  • RFC 4315: Internet Message Access Protocol (IMAP) - UIDPLUS extension

    Proposed Standard
  • RFC 4314: IMAP4 Access Control List (ACL) Extension

    Proposed Standard
  • RFC 3807: V5.2-User Adaptation Layer (V5UA)

    Proposed Standard
  • RFC 3691: Internet Message Access Protocol (IMAP) UNSELECT command

    Proposed Standard
  • RFC 3656: The Mailbox Update (MUPDATE) Distributed Mailbox Database Protocol

    Experimental
  • RFC 3516: IMAP4 Binary Content Extension

    Proposed Standard
  • RFC 3501: INTERNET MESSAGE ACCESS PROTOCOL - VERSION 4rev1

    Proposed Standard

    Obsoleted by RFC 9051

  • RFC 3502: Internet Message Access Protocol (IMAP) - MULTIAPPEND Extension

    Proposed Standard
  • RFC 3503: Message Disposition Notification (MDN) profile for Internet Message Access Protocol (IMAP)

    Proposed Standard
  • RFC 3348: The Internet Message Action Protocol (IMAP4) Child Mailbox Extension

    Informational
  • RFC 2971: IMAP4 ID extension

    Proposed Standard
  • RFC 2683: IMAP4 Implementation Recommendations

    Informational
  • RFC 2595: Using TLS with IMAP, POP3 and ACAP

    Proposed Standard
  • RFC 2359: IMAP4 UIDPLUS extension

    Proposed Standard

    Obsoleted by RFC 4315

  • RFC 2342: IMAP4 Namespace

    Proposed Standard
  • RFC 2221: IMAP4 Login Referrals

    Proposed Standard
  • RFC 2192: IMAP URL Scheme

    Proposed Standard

    Obsoleted by RFC 5092

  • RFC 2193: IMAP4 Mailbox Referrals

    Proposed Standard
  • RFC 2195: IMAP/POP AUTHorize Extension for Simple Challenge/Response

    Proposed Standard
  • RFC 2180: IMAP4 Multi-Accessed Mailbox Practice

    Informational
  • RFC 2177: IMAP4 IDLE command

    Proposed Standard
  • RFC 2086: IMAP4 ACL extension

    Proposed Standard

    Obsoleted by RFC 4314

  • RFC 2087: IMAP4 QUOTA extension

    Proposed Standard

    Obsoleted by RFC 9208

  • RFC 2088: IMAP4 non-synchronizing literals

    Proposed Standard

    Obsoleted by RFC 7888

  • RFC 2095: IMAP/POP AUTHorize Extension for Simple Challenge/Response

    Proposed Standard

    Obsoleted by RFC 2195

  • RFC 2060: Internet Message Access Protocol - Version 4rev1

    Proposed Standard

    Obsoleted by RFC 3501

  • RFC 2061: IMAP4 Compatibility with IMAP2bis

    Informational
  • RFC 2062: Internet Message Access Protocol - Obsolete Syntax

    Informational
  • RFC 1730: Internet Message Access Protocol - Version 4

    Proposed Standard

    Obsoleted by RFC 2060, RFC 2061

  • RFC 1731: IMAP4 Authentication Mechanisms

    Proposed Standard
  • RFC 1732: IMAP4 Compatibility with IMAP2 and IMAP2bis

    Informational
  • RFC 1733: Distributed Electronic Mail Models in IMAP4

    Informational
  • RFC 1203: Interactive Mail Access Protocol: Version 3

    Historic
  • RFC 1176: Interactive Mail Access Protocol: Version 2

    Experimental
  • RFC 1064: Interactive Mail Access Protocol: Version 2

    Unknown

    Obsoleted by RFC 1176, RFC 1203

Subscribe to IMAP

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.