WHOIS

WHOIS and legacy registration data directory services

WHOIS subjects:

WHOIS RFCs (47)

Display RFCs as
  • RFC 9224: STD 95: Finding the Authoritative Registration Data Access Protocol (RDAP) Service

    Internet Standard
  • RFC 7480: STD 95: HTTP Usage in the Registration Data Access Protocol (RDAP)

    Internet Standard
  • RFC 7482: Registration Data Access Protocol (RDAP) Query Format

    Proposed Standard

    Obsoleted by RFC 9082

  • RFC 7483: JSON Responses for the Registration Data Access Protocol (RDAP)

    Proposed Standard

    Obsoleted by RFC 9083

  • RFC 7484: Finding the Authoritative Registration Data (RDAP) Service

    Proposed Standard

    Obsoleted by RFC 9224

  • RFC 7485: Inventory and Analysis of WHOIS Registration Objects

    Informational
  • RFC 5144: A Domain Availability Check (DCHK) Registry Type for the Internet Registry Information Service (IRIS)

    Proposed Standard
  • RFC 4991: A Common Schema for Internet Registry Information Service Transfer Protocols

    Proposed Standard
  • RFC 4992: XML Pipelining with Chunks for the Internet Registry Information Service

    Proposed Standard
  • RFC 4993: A Lightweight UDP Transfer Protocol for the Internet Registry Information Service

    Proposed Standard
  • RFC 4698: IRIS: An Address Registry (areg) Type for the Internet Registry Information Service

    Proposed Standard
  • RFC 3981: IRIS: The Internet Registry Information Service (IRIS) Core Protocol

    Proposed Standard
  • RFC 3982: IRIS: A Domain Registry (dreg) Type for the Internet Registry Information Service (IRIS)

    Proposed Standard
  • RFC 3983: Using the Internet Registry Information Service (IRIS) over the Blocks Extensible Exchange Protocol (BEEP)

    Proposed Standard
  • RFC 3912: WHOIS Protocol Specification

    Draft Standard
  • RFC 3707: Cross Registry Internet Service Protocol (CRISP) Requirements

    Informational
  • RFC 2651: The Architecture of the Common Indexing Protocol (CIP)

    Proposed Standard
  • RFC 2652: MIME Object Definitions for the Common Indexing Protocol (CIP)

    Proposed Standard
  • RFC 2653: CIP Transport Protocols

    Proposed Standard
  • RFC 2654: A Tagged Index Object for use in the Common Indexing Protocol

    Experimental
  • RFC 2655: CIP Index Object Format for SOIF Objects

    Experimental
  • RFC 2656: Registration Procedures for SOIF Template Types

    Experimental
  • RFC 2657: LDAPv2 Client vs. the Index Mesh

    Experimental
  • RFC 2425: A MIME Content-Type for Directory Information

    Proposed Standard

    Obsoleted by RFC 6350

  • RFC 2426: vCard MIME Directory Profile

    Proposed Standard

    Obsoleted by RFC 6350

  • RFC 2345: Domain Names and Company Name Retrieval

    Experimental
  • RFC 2247: Using Domains in LDAP/X.500 Distinguished Names

    Proposed Standard
  • RFC 2251: Lightweight Directory Access Protocol (v3)

    Proposed Standard

    Obsoleted by RFC 4510, RFC 4511, RFC 4512, RFC 4513

  • RFC 2252: Lightweight Directory Access Protocol (v3): Attribute Syntax Definitions

    Proposed Standard

    Obsoleted by RFC 4510, RFC 4512, RFC 4517, RFC 4523

  • RFC 2253: Lightweight Directory Access Protocol (v3): UTF-8 String Representation of Distinguished Names

    Proposed Standard

    Obsoleted by RFC 4510, RFC 4514

  • RFC 2254: The String Representation of LDAP Search Filters

    Proposed Standard

    Obsoleted by RFC 4510, RFC 4515

  • RFC 2255: The LDAP URL Format

    Proposed Standard

    Obsoleted by RFC 4510, RFC 4516

  • RFC 2256: A Summary of the X.500(96) User Schema for use with LDAPv3

    Proposed Standard

    Obsoleted by RFC 4510, RFC 4512, RFC 4517, RFC 4519, RFC 4523

  • RFC 2079: Definition of an X.500 Attribute Type and an Object Class to Hold Uniform Resource Identifiers (URIs)

    Proposed Standard
  • RFC 1959: An LDAP URL Format

    Proposed Standard

    Obsoleted by RFC 2255

  • RFC 1960: A String Representation of LDAP Search Filters

    Proposed Standard

    Obsoleted by RFC 2254

  • RFC 1804: Schema Publishing in X.500 Directory

    Experimental
  • RFC 1777: Lightweight Directory Access Protocol

    Historic

    Obsoleted by RFC 3494

  • RFC 1778: The String Representation of Standard Attribute Syntaxes

    Historic

    Obsoleted by RFC 3494

  • RFC 1779: A String Representation of Distinguished Names

    Historic

    Obsoleted by RFC 2253, RFC 3494

  • RFC 1781: Using the OSI Directory to Achieve User Friendly Naming

    Historic

    Obsoleted by RFC 3494

  • RFC 1739: A Primer On Internet and TCP/IP Tools

    Informational

    Obsoleted by RFC 2151

  • RFC 1580: FYI 23: Guide to Network Resource Tools

    Informational
  • RFC 1373: Portable DUAs

    Informational
  • RFC 1190: Experimental Internet Stream Protocol: Version 2 (ST-II)

    Experimental

    Obsoleted by RFC 1819

  • RFC 954: NICNAME/WHOIS

    Draft Standard

    Obsoleted by RFC 3912

  • RFC 812: NICNAME/WHOIS

    Unknown

    Obsoleted by RFC 954, RFC 3912

Subscribe to WHOIS

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.