Diffserv

Diffserv (Differentiated Services)

Diffserv RFCs (60)

Display RFCs as
  • RFC 9956: A Non-Queue-Building Per-Hop Behavior (NQB PHB) for Differentiated Services

    Proposed Standard
  • Proposed Standard
  • Proposed Standard
  • Informational
  • RFC 9145: Integrity Protection for the Network Service Header (NSH) and Encryption of Sensitive Context Headers

    Proposed Standard
  • RFC 8837: Differentiated Services Code Point (DSCP) Packet Markings for WebRTC QoS

    Proposed Standard
  • RFC 8622: A Lower-Effort Per-Hop Behavior (LE PHB) for Differentiated Services

    Proposed Standard
  • RFC 8459: Hierarchical Service Function Chaining (hSFC)

    Experimental
  • RFC 8436: Update to IANA Registration Procedures for Pool 3 Values in the Differentiated Services Field Codepoints (DSCP) Registry

    Proposed Standard
  • RFC 8325: Mapping Diffserv to IEEE 802.11

    Proposed Standard
  • RFC 8100: Diffserv-Interconnection Classes and Practice

    Informational
  • RFC 7657: Differentiated Services (Diffserv) and Real-Time Communication

    Informational
  • RFC 6660: Encoding Three Pre-Congestion Notification (PCN) States in the IP Header Using a Single Diffserv Codepoint (DSCP)

    Proposed Standard
  • RFC 6663: Requirements for Signaling of Pre-Congestion Information in a Diffserv Domain

    Informational
  • RFC 5977: RMD-QOSM: The NSIS Quality-of-Service Model for Resource Management in Diffserv

    Experimental
  • RFC 5865: A Differentiated Services Code Point (DSCP) for Capacity-Admitted Traffic

    Proposed Standard
  • RFC 5696: Baseline Encoding and Transport of Pre-Congestion Information

    Proposed Standard

    Obsoleted by RFC 6660

  • RFC 5559: Pre-Congestion Notification (PCN) Architecture

    Informational
  • RFC 5455: Diffserv-Aware Class-Type Object for the Path Computation Element Communication Protocol

    Proposed Standard
  • RFC 5160: Considerations of Provider-to-Provider Agreements for Internet-Scale Quality of Service (QoS)

    Informational
  • RFC 5127: Aggregation of Diffserv Service Classes

    Informational
  • RFC 5129: Explicit Congestion Marking in MPLS

    Proposed Standard
  • RFC 4804: Aggregation of Resource ReSerVation Protocol (RSVP) Reservations over MPLS TE/DS-TE Tunnels

    Proposed Standard
  • RFC 4594: Configuration Guidelines for DiffServ Service Classes

    Informational
  • RFC 4115: A Differentiated Service Two-Rate, Three-Color Marker with Efficient Handling of in-Profile Traffic

    Informational
  • RFC 4124: Protocol Extensions for Support of Diffserv-aware MPLS Traffic Engineering

    Proposed Standard
  • RFC 4125: Maximum Allocation Bandwidth Constraints Model for Diffserv-aware MPLS Traffic Engineering

    Experimental
  • RFC 4126: Max Allocation with Reservation Bandwidth Constraints Model for Diffserv-aware MPLS Traffic Engineering & Performance Comparisons

    Experimental
  • RFC 4127: Russian Dolls Bandwidth Constraints Model for Diffserv-aware MPLS Traffic Engineering

    Experimental
  • RFC 4128: Bandwidth Constraints Models for Differentiated Services (Diffserv)-aware MPLS Traffic Engineering: Performance Evaluation

    Informational
  • RFC 3754: IP Multicast in Differentiated Services (DS) Networks

    Informational
  • RFC 3747: The Differentiated Services Configuration MIB

    Proposed Standard
  • RFC 3662: A Lower Effort Per-Domain Behavior (PDB) for Differentiated Services

    Informational

    Obsoleted by RFC 8622

  • RFC 3564: Requirements for Support of Differentiated Services-aware MPLS Traffic Engineering

    Informational
  • RFC 3496: Protocol Extension for Support of Asynchronous Transfer Mode (ATM) Service Class-aware Multiprotocol Label Switching (MPLS) Traffic Engineering

    Informational
  • RFC 3317: Differentiated Services Quality of Service Policy Information Base

    Historic
  • RFC 3308: Layer Two Tunneling Protocol (L2TP) Differentiated Services Extension

    Proposed Standard
  • RFC 3287: Remote Monitoring MIB Extensions for Differentiated Services

    Proposed Standard
  • RFC 3289: Management Information Base for the Differentiated Services Architecture

    Proposed Standard
  • RFC 3290: An Informal Management Model for Diffserv Routers

    Informational
  • RFC 3270: Multi-Protocol Label Switching (MPLS) Support of Differentiated Services

    Proposed Standard
  • RFC 3260: New Terminology and Clarifications for Diffserv

    Informational
  • RFC 3246: An Expedited Forwarding PHB (Per-Hop Behavior)

    Proposed Standard
  • RFC 3247: Supplemental Information for the New Definition of the EF PHB (Expedited Forwarding Per-Hop Behavior)

    Informational
  • RFC 3248: A Delay Bound alternative revision of RFC 2598

    Informational
  • RFC 3140: Per Hop Behavior Identification Codes

    Proposed Standard
  • RFC 3086: Definition of Differentiated Services Per Domain Behaviors and Rules for their Specification

    Informational
  • RFC 2998: A Framework for Integrated Services Operation over Diffserv Networks

    Informational
  • RFC 2963: A Rate Adaptive Shaper for Differentiated Services

    Informational
  • RFC 2983: Differentiated Services and Tunnels

    Informational
  • RFC 2859: A Time Sliding Window Three Colour Marker (TSWTCM)

    Experimental
  • RFC 2836: Per Hop Behavior Identification Codes

    Proposed Standard

    Obsoleted by RFC 3140

  • RFC 2697: A Single Rate Three Color Marker

    Informational
  • RFC 2698: A Two Rate Three Color Marker

    Informational
  • RFC 2638: A Two-bit Differentiated Services Architecture for the Internet

    Informational
  • RFC 2597: Assured Forwarding PHB Group

    Proposed Standard
  • RFC 2598: An Expedited Forwarding PHB

    Proposed Standard

    Obsoleted by RFC 3246

  • RFC 2474: Definition of the Differentiated Services Field (DS Field) in the IPv4 and IPv6 Headers

    Proposed Standard
  • RFC 2475: An Architecture for Differentiated Services

    Informational
  • RFC 2430: A Provider Architecture for Differentiated Services and Traffic Engineering (PASTE)

    Informational

Subscribe to Diffserv

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.