MD5

MD5 (Message Digest 5) and the MD2/MD4 message digests

MD5 RFCs (33)

Display RFCs as
  • RFC 9765: RADIUS/1.1: Leveraging Application-Layer Protocol Negotiation (ALPN) to Remove MD5

    Experimental
  • RFC 9314: YANG Data Model for Bidirectional Forwarding Detection (BFD)

    Proposed Standard
  • RFC 9155: Deprecating MD5 and SHA-1 Signature Hashes in TLS 1.2 and DTLS 1.2

    Proposed Standard
  • RFC 9127: YANG Data Model for Bidirectional Forwarding Detection (BFD)

    Proposed Standard
  • RFC 8976: Message Digest for DNS Zones

    Proposed Standard
  • RFC 6331: Moving DIGEST-MD5 to Historic

    Informational
  • RFC 6210: Experiment: Hash Functions with Parameters in the Cryptographic Message Syntax (CMS) and S/MIME

    Experimental
  • RFC 6149: MD2 to Historic Status

    Informational
  • RFC 6150: MD4 to Historic Status

    Informational
  • RFC 6151: Updated Security Considerations for the MD5 Message-Digest and the HMAC-MD5 Algorithms

    Informational
  • RFC 5754: Using SHA2 Algorithms with Cryptographic Message Syntax

    Proposed Standard
  • RFC 5304: IS-IS Cryptographic Authentication

    Proposed Standard
  • RFC 4894: Use of Hash Algorithms in Internet Key Exchange (IKE) and IPsec

    Informational
  • RFC 4808: Key Change Strategies for TCP-MD5

    Informational
  • RFC 4822: RIPv2 Cryptographic Authentication

    Proposed Standard
  • RFC 4757: The RC4-HMAC Kerberos Encryption Types Used by Microsoft Windows

    Historic
  • RFC 4491: Using the GOST R 34.10-94, GOST R 34.10-2001, and GOST R 34.11-94 Algorithms with the Internet X.509 Public Key Infrastructure Certificate and CRL Profile

    Proposed Standard
  • RFC 4278: Standards Maturity Variance Regarding the TCP MD5 Signature Option (RFC 2385) and the BGP-4 Specification

    Informational
  • RFC 3562: Key Management Considerations for the TCP MD5 Signature Option

    Informational
  • RFC 2537: RSA/MD5 KEYs and SIGs in the Domain Name System (DNS)

    Proposed Standard

      Obsoleted by RFC 3110

  • RFC 2403: The Use of HMAC-MD5-96 within ESP and AH

    Proposed Standard
  • RFC 2385: Protection of BGP Sessions via the TCP MD5 Signature Option

    Proposed Standard

      Obsoleted by RFC 5925

  • RFC 2202: Test Cases for HMAC-MD5 and HMAC-SHA-1

    Informational
  • RFC 2085: HMAC-MD5 IP Authentication with Replay Prevention

    Proposed Standard
  • RFC 2082: RIP-2 MD5 Authentication

    Proposed Standard

      Obsoleted by RFC 4822

  • RFC 1864: The Content-MD5 Header Field

    Draft Standard
  • RFC 1828: IP Authentication using Keyed MD5

    Historic
  • RFC 1810: Report on MD5 Performance

    Informational
  • RFC 1544: The Content-MD5 Header Field

    Proposed Standard

      Obsoleted by RFC 1864

  • RFC 1319: The MD2 Message-Digest Algorithm

    Historic

      Obsoleted by RFC 6149

  • RFC 1320: The MD4 Message-Digest Algorithm

    Historic

      Obsoleted by RFC 6150

  • RFC 1321: The MD5 Message-Digest Algorithm

    Informational
  • RFC 1186: MD4 Message Digest Algorithm

    Informational

      Obsoleted by RFC 1320

Subscribe to MD5

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.