IGMP

IGMP (Internet Group Management Protocol)

IGMP RFCs (24)

Display RFCs as
  • RFC 9398: A YANG Data Model for Internet Group Management Protocol (IGMP) and Multicast Listener Discovery (MLD) Proxy Devices

    Proposed Standard
  • RFC 9251: Internet Group Management Protocol (IGMP) and Multicast Listener Discovery (MLD) Proxies for Ethernet VPN (EVPN)

    Proposed Standard
  • RFC 9166: A YANG Data Model for Internet Group Management Protocol (IGMP) and Multicast Listener Discovery (MLD) Snooping

    Proposed Standard
  • RFC 8652: A YANG Data Model for the Internet Group Management Protocol (IGMP) and Multicast Listener Discovery (MLD)

    Proposed Standard
  • RFC 8114: Delivery of IPv4 Multicast Services to IPv4 Clients over an IPv6 Multicast Network

    Proposed Standard
  • RFC 7028: Multicast Mobility Routing Optimizations for Proxy Mobile IPv6

    Experimental
  • RFC 6636: Tuning the Behavior of the Internet Group Management Protocol (IGMP) and Multicast Listener Discovery (MLD) for Routers in Mobile and Wireless Networks

    Informational
  • RFC 5790: Lightweight Internet Group Management Protocol Version 3 (IGMPv3) and Multicast Listener Discovery Version 2 (MLDv2) Protocols

    Proposed Standard
  • RFC 5519: Multicast Group Membership Discovery MIB

    Proposed Standard
  • RFC 5501: Requirements for Multicast Support in Virtual Private LAN Services

    Informational
  • RFC 5186: Internet Group Management Protocol Version 3 (IGMPv3) / Multicast Listener Discovery Version 2 (MLDv2) and Multicast Routing Protocol Interaction

    Informational
  • RFC 4604: Using Internet Group Management Protocol Version 3 (IGMPv3) and Multicast Listener Discovery Protocol Version 2 (MLDv2) for Source-Specific Multicast

    Proposed Standard
  • RFC 4605: Internet Group Management Protocol (IGMP) / Multicast Listener Discovery (MLD)-Based Multicast Forwarding ("IGMP/MLD Proxying")

    Proposed Standard
  • RFC 4541: Considerations for Internet Group Management Protocol (IGMP) and Multicast Listener Discovery (MLD) Snooping Switches

    Informational
  • RFC 4286: Multicast Router Discovery

    Proposed Standard
  • RFC 3810: Multicast Listener Discovery Version 2 (MLDv2) for IPv6

    Proposed Standard

      Obsoleted by RFC 9777

  • RFC 3678: Socket Interface Extensions for Multicast Source Filters

    Informational
  • RFC 3590: Source Address Selection for the Multicast Listener Discovery (MLD) Protocol

    Proposed Standard
  • RFC 3376: Internet Group Management Protocol, Version 3

    Proposed Standard

      Obsoleted by RFC 9776

  • RFC 3228: IANA Considerations for IPv4 Internet Group Management Protocol (IGMP)

    Best Current Practice

      Obsoleted by RFC 9778

  • RFC 2933: Internet Group Management Protocol MIB

    Proposed Standard

      Obsoleted by RFC 5519

  • RFC 2236: Internet Group Management Protocol, Version 2

    Proposed Standard
  • RFC 1885: Internet Control Message Protocol (ICMPv6) for the Internet Protocol Version 6 (IPv6)

    Proposed Standard

      Obsoleted by RFC 2463

  • RFC 1112: STD 5: Host extensions for IP multicasting

    Internet Standard

Subscribe to IGMP

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.