Unicode

Unicode usage in Internet protocols

Unicode RFCs (31)

Display RFCs as
  • RFC 9839: Unicode Character Repertoire Subsets

    Proposed Standard
  • RFC 9233: Internationalized Domain Names for Applications 2008 (IDNA2008) and Unicode 12.0.0

    Proposed Standard
  • RFC 8753: Internationalized Domain Names for Applications (IDNA) Review for New Unicode Versions

    Proposed Standard
  • RFC 8265: Preparation, Enforcement, and Comparison of Internationalized Strings Representing Usernames and Passwords

    Proposed Standard
  • RFC 7613: Preparation, Enforcement, and Comparison of Internationalized Strings Representing Usernames and Passwords

    Proposed Standard

    Obsoleted by RFC 8265

  • RFC 7373: Textual Representation of IP Flow Information Export (IPFIX) Abstract Data Types

    Proposed Standard
  • RFC 6912: Principles for Unicode Code Point Inclusion in Labels in the DNS

    Informational
  • RFC 6409: STD 72: Message Submission for Mail

    Internet Standard
  • RFC 6452: The Unicode Code Points and Internationalized Domain Names for Applications (IDNA) - Unicode 6.0

    Proposed Standard
  • RFC 6055: IAB Thoughts on Encodings for Internationalized Domain Names

    Informational
  • RFC 6067: BCP 47 Extension U

    Informational
  • RFC 6082: Deprecating Unicode Language Tag Characters: RFC 2482 is Historic

    Informational
  • RFC 5895: Mapping Characters for Internationalized Domain Names in Applications (IDNA) 2008

    Informational
  • RFC 5892: The Unicode Code Points and Internationalized Domain Names for Applications (IDNA)

    Proposed Standard
  • RFC 5335: Internationalized Email Headers

    Experimental

    Obsoleted by RFC 6532

  • RFC 5198: Unicode Format for Network Interchange

    Proposed Standard
  • RFC 5137: BCP 137: ASCII Escaping of Unicode Characters

    Best Current Practice
  • RFC 5051: i;unicode-casemap - Simple Unicode Collation Algorithm

    Proposed Standard
  • RFC 4013: SASLprep: Stringprep Profile for User Names and Passwords

    Proposed Standard

    Obsoleted by RFC 7613

  • RFC 3718: A Summary of Unicode Consortium Procedures, Policies, Stability, and Public Access

    Informational
  • RFC 3629: STD 63: UTF-8, a transformation format of ISO 10646

    Internet Standard
  • RFC 3492: Punycode: A Bootstring encoding of Unicode for Internationalized Domain Names in Applications (IDNA)

    Proposed Standard
  • RFC 3467: Role of the Domain Name System (DNS)

    Informational
  • RFC 3454: Preparation of Internationalized Strings ("stringprep")

    Proposed Standard

    Obsoleted by RFC 7564

  • RFC 2781: UTF-16, an encoding of ISO 10646

    Informational
  • RFC 2482: Language Tagging in Unicode Plain Text

    Historic

    Obsoleted by RFC 6082

  • RFC 2279: UTF-8, a transformation format of ISO 10646

    Draft Standard

    Obsoleted by RFC 3629

  • RFC 2152: UTF-7 A Mail-Safe Transformation Format of Unicode

    Informational
  • RFC 2044: UTF-8, a transformation format of Unicode and ISO 10646

    Informational

    Obsoleted by RFC 2279

  • RFC 1641: Using Unicode with MIME

    Experimental
  • RFC 1642: UTF-7 - A Mail-Safe Transformation Format of Unicode

    Experimental

    Obsoleted by RFC 2152

Subscribe to Unicode

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.