RDAP

RDAP (Registration Data Access Protocol)

RDAP RFCs (36)

Display RFCs as
  • RFC 10037: Registration Data Access Protocol (RDAP) Extension for DNS Time-to-Live (TTL) Values

    Proposed Standard
  • Proposed Standard
  • RFC 9873: Additional Email Address Extension for the Extensible Provisioning Protocol (EPP)

    Proposed Standard
  • RFC 9877: Registration Data Access Protocol (RDAP) Extension for Geofeed Data

    Proposed Standard
  • RFC 9874: BCP 244: Best Practices for Deletion of Domain and Host Objects in the Extensible Provisioning Protocol (EPP)

    Best Current Practice
  • RFC 9803: Extensible Provisioning Protocol (EPP) Mapping for DNS Time-to-Live (TTL) Values

    Proposed Standard
  • RFC 9560: Federated Authentication for the Registration Data Access Protocol (RDAP) Using OpenID Connect

    Proposed Standard
  • Proposed Standard
  • RFC 9537: Redacted Fields in the Registration Data Access Protocol (RDAP) Response

    Proposed Standard
  • RFC 9224: STD 95: Finding the Authoritative Registration Data Access Protocol (RDAP) Service

    Internet Standard
  • RFC 9154: Extensible Provisioning Protocol (EPP) Secure Authorization Information for Transfer

    Proposed Standard
  • RFC 9167: Registry Maintenance Notification for the Extensible Provisioning Protocol (EPP)

    Proposed Standard
  • RFC 9082: STD 95: Registration Data Access Protocol (RDAP) Query Format

    Internet Standard
  • RFC 9083: STD 95: JSON Responses for the Registration Data Access Protocol (RDAP)

    Internet Standard
  • RFC 9038: Extensible Provisioning Protocol (EPP) Unhandled Namespaces

    Proposed Standard
  • RFC 9022: Domain Name Registration Data (DNRD) Objects Mapping

    Proposed Standard
  • RFC 8982: Registration Data Access Protocol (RDAP) Partial Response

    Proposed Standard
  • RFC 8977: Registration Data Access Protocol (RDAP) Query Parameters for Result Sorting and Paging

    Proposed Standard
  • RFC 8909: Registry Data Escrow Specification

    Proposed Standard
  • RFC 8807: Login Security Extension for the Extensible Provisioning Protocol (EPP)

    Proposed Standard
  • RFC 8748: Registry Fee Extension for the Extensible Provisioning Protocol (EPP)

    Proposed Standard
  • RFC 8605: vCard Format Extensions: ICANN Extensions for the Registration Data Access Protocol (RDAP)

    Informational
  • RFC 8590: Change Poll Extension for the Extensible Provisioning Protocol (EPP)

    Proposed Standard
  • RFC 8544: Organization Extension for the Extensible Provisioning Protocol (EPP)

    Proposed Standard
  • RFC 8543: Extensible Provisioning Protocol (EPP) Organization Mapping

    Proposed Standard
  • RFC 8495: Allocation Token Extension for the Extensible Provisioning Protocol (EPP)

    Proposed Standard
  • RFC 8521: BCP 221: Registration Data Access Protocol (RDAP) Object Tagging

    Best Current Practice
  • RFC 8334: Launch Phase Mapping for the Extensible Provisioning Protocol (EPP)

    Proposed Standard
  • RFC 8063: Key Relay Mapping for the Extensible Provisioning Protocol

    Proposed Standard
  • RFC 8056: Extensible Provisioning Protocol (EPP) and Registration Data Access Protocol (RDAP) Status Mapping

    Proposed Standard
  • RFC 7480: STD 95: HTTP Usage in the Registration Data Access Protocol (RDAP)

    Internet Standard
  • RFC 7481: STD 95: Security Services for the Registration Data Access Protocol (RDAP)

    Internet Standard
  • RFC 7482: Registration Data Access Protocol (RDAP) Query Format

    Proposed Standard

    Obsoleted by RFC 9082

  • RFC 7483: JSON Responses for the Registration Data Access Protocol (RDAP)

    Proposed Standard

    Obsoleted by RFC 9083

  • RFC 7484: Finding the Authoritative Registration Data (RDAP) Service

    Proposed Standard

    Obsoleted by RFC 9224

  • RFC 7485: Inventory and Analysis of WHOIS Registration Objects

    Informational

Subscribe to RDAP

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.