HMAC

HMAC (Hash-based Message Authentication Code)

HMAC RFCs (34)

Display RFCs as
  • RFC 9053: CBOR Object Signing and Encryption (COSE): Initial Algorithms

    Informational
  • RFC 9150: TLS 1.3 Authentication and Integrity-Only Cipher Suites

    Informational
  • RFC 8619: Algorithm Identifiers for the HMAC-based Extract-and-Expand Key Derivation Function (HKDF)

    Proposed Standard
  • RFC 8009: AES Encryption with HMAC-SHA2 for Kerberos 5

    Informational
  • RFC 7860: HMAC-SHA-2 Authentication Protocols in User-Based Security Model (USM) for SNMPv3

    Proposed Standard
  • RFC 7836: Guidelines on the Cryptographic Algorithms to Accompany the Usage of Standards GOST R 34.10-2012 and GOST R 34.11-2012

    Informational
  • RFC 7630: HMAC-SHA-2 Authentication Protocols in the User-based Security Model (USM) for SNMPv3

    Proposed Standard

      Obsoleted by RFC 7860

  • RFC 7298: Babel Hashed Message Authentication Code (HMAC) Cryptographic Authentication

    Experimental

      Obsoleted by RFC 8967

  • RFC 6649: BCP 179: Deprecate DES, RC4-HMAC-EXP, and Other Weak Cryptographic Algorithms in Kerberos

    Best Current Practice
  • RFC 6268: Additional New ASN.1 Modules for the Cryptographic Message Syntax (CMS) and the Public Key Infrastructure Using X.509 (PKIX)

    Informational
  • RFC 6234: US Secure Hash Algorithms (SHA and SHA-based HMAC and HKDF)

    Informational
  • RFC 6151: Updated Security Considerations for the MD5 Message-Digest and the HMAC-MD5 Algorithms

    Informational
  • RFC 5869: HMAC-based Extract-and-Expand Key Derivation Function (HKDF)

    Informational
  • RFC 5709: OSPFv2 HMAC-SHA Cryptographic Authentication

    Proposed Standard
  • RFC 5310: IS-IS Generic Cryptographic Authentication

    Proposed Standard
  • RFC 5304: IS-IS Cryptographic Authentication

    Proposed Standard
  • RFC 4895: Authenticated Chunks for the Stream Control Transmission Protocol (SCTP)

    Proposed Standard
  • RFC 4868: Using HMAC-SHA-256, HMAC-SHA-384, and HMAC-SHA-512 with IPsec

    Proposed Standard
  • RFC 4757: The RC4-HMAC Kerberos Encryption Types Used by Microsoft Windows

    Historic
  • RFC 4650: HMAC-Authenticated Diffie-Hellman for Multimedia Internet KEYing (MIKEY)

    Proposed Standard
  • RFC 4635: HMAC SHA (Hashed Message Authentication Code, Secure Hash Algorithm) TSIG Algorithm Identifiers

    Proposed Standard

      Obsoleted by RFC 8945

  • RFC 4634: US Secure Hash Algorithms (SHA and HMAC-SHA)

    Informational

      Obsoleted by RFC 6234

  • RFC 4490: Using the GOST 28147-89, GOST R 34.11-94, GOST R 34.10-94, and GOST R 34.10-2001 Algorithms with Cryptographic Message Syntax (CMS)

    Proposed Standard
  • RFC 4357: Additional Cryptographic Algorithms for Use with GOST 28147-89, GOST R 34.10-94, GOST R 34.10-2001, and GOST R 34.11-94 Algorithms

    Informational
  • RFC 4226: HOTP: An HMAC-Based One-Time Password Algorithm

    Informational
  • RFC 4231: Identifiers and Test Vectors for HMAC-SHA-224, HMAC-SHA-256, HMAC-SHA-384, and HMAC-SHA-512

    Proposed Standard
  • RFC 3537: Wrapping a Hashed Message Authentication Code (HMAC) key with a Triple-Data Encryption Standard (DES) Key or an Advanced Encryption Standard (AES) Key

    Proposed Standard
  • RFC 2857: The Use of HMAC-RIPEMD-160-96 within ESP and AH

    Proposed Standard
  • RFC 2403: The Use of HMAC-MD5-96 within ESP and AH

    Proposed Standard
  • RFC 2404: The Use of HMAC-SHA-1-96 within ESP and AH

    Proposed Standard
  • RFC 2286: Test Cases for HMAC-RIPEMD160 and HMAC-RIPEMD128

    Informational
  • RFC 2202: Test Cases for HMAC-MD5 and HMAC-SHA-1

    Informational
  • RFC 2085: HMAC-MD5 IP Authentication with Replay Prevention

    Proposed Standard
  • RFC 2104: HMAC: Keyed-Hashing for Message Authentication

    Informational

Subscribe to HMAC

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.