OpenPGP

OpenPGP (Open Pretty Good Privacy) message format and usage

OpenPGP RFCs (15)

Display RFCs as
  • RFC 9980: Post-Quantum Cryptography in OpenPGP

    Proposed Standard
  • RFC 9788: Header Protection for Cryptographically Protected Email

    Proposed Standard
  • RFC 9580: OpenPGP

    Proposed Standard
  • RFC 7929: DNS-Based Authentication of Named Entities (DANE) Bindings for OpenPGP

    Experimental
  • RFC 7681: Email Exchange of Secondary School Transcripts

    Informational
  • RFC 6637: Elliptic Curve Cryptography (ECC) in OpenPGP

    Proposed Standard

      Obsoleted by RFC 9580

  • RFC 6091: Using OpenPGP Keys for Transport Layer Security (TLS) Authentication

    Informational
  • RFC 5581: The Camellia Cipher in OpenPGP

    Informational

      Obsoleted by RFC 9580

  • RFC 4880: OpenPGP Message Format

    Proposed Standard

      Obsoleted by RFC 9580

  • RFC 5081: Using OpenPGP Keys for Transport Layer Security (TLS) Authentication

    Experimental

      Obsoleted by RFC 6091

  • RFC 3156: MIME Security with OpenPGP

    Proposed Standard
  • RFC 2726: PGP Authentication for RIPE Database Updates

    Proposed Standard
  • RFC 2440: OpenPGP Message Format

    Proposed Standard

      Obsoleted by RFC 4880

  • RFC 2015: MIME Security with Pretty Good Privacy (PGP)

    Proposed Standard
  • RFC 1991: PGP Message Exchange Formats

    Informational

      Obsoleted by RFC 4880

Subscribe to OpenPGP

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.