SigComp
SigComp (Signaling Compression) for SIP and other text-based signaling
Within this page
SigComp RFCs (10)
RFC 5112: The Presence-Specific Static Dictionary for Signaling Compression (Sigcomp)
Proposed Standard- M. Garcia-Martin
- January 2008
- IETF publication
Abstract
The Session Initiation Protocol (SIP) is a text-based protocol for initiating and managing communication sessions. The protocol is extended by the SIP-events notification framework to provide subscriptions and notifications of SIP events. One example of such event notification mechanism is presence, which is expressed in XML documents called presence documents. SIP can be compressed by using Signaling Compression (SigComp), which is enhanced by using the SIP/ Session Description Protocol (SDP) dictionary to achieve better compression rates. However, the SIP/SDP dictionary is not able to increase the compression factor of (typically lengthy) presence documents. This memo defines the presence-specific static dictionary that SigComp can use in order to compress presence documents to achieve higher efficiency. The dictionary is compression-algorithm independent. [STANDARDS-TRACK]
Abstract
The Session Initiation Protocol (SIP) is a text-based protocol for initiating and managing communication sessions. The protocol is extended by the SIP-events notification framework to provide subscriptions and notifications of SIP events. One example of such event notification mechanism is presence, which is expressed in XML documents called presence documents. SIP can be compressed by using Signaling Compression (SigComp), which is enhanced by using the SIP/ Session Description Protocol (SDP) dictionary to achieve better compression rates. However, the SIP/SDP dictionary is not able to increase the compression factor of (typically lengthy) presence documents. This memo defines the presence-specific static dictionary that SigComp can use in order to compress presence documents to achieve higher efficiency. The dictionary is compression-algorithm independent. [STANDARDS-TRACK]
RFC 5049: Applying Signaling Compression (SigComp) to the Session Initiation Protocol (SIP)
Proposed Standard- C. Bormann
- Z. Liu
- R. Price
- G. Camarillo
- December 2007
- IETF publication
- Transport Area
Abstract
This document describes some specifics that apply when Signaling Compression (SigComp) is applied to the Session Initiation Protocol (SIP), such as default minimum values of SigComp parameters, compartment and state management, and a few issues on SigComp over TCP. Any implementation of SigComp for use with SIP must conform to this document and SigComp, and in addition, support the SIP and Session Description Protocol (SDP) static dictionary. [STANDARDS-TRACK]
Abstract
This document describes some specifics that apply when Signaling Compression (SigComp) is applied to the Session Initiation Protocol (SIP), such as default minimum values of SigComp parameters, compartment and state management, and a few issues on SigComp over TCP. Any implementation of SigComp for use with SIP must conform to this document and SigComp, and in addition, support the SIP and Session Description Protocol (SDP) static dictionary. [STANDARDS-TRACK]
RFC 4896: Signaling Compression (SigComp) Corrections and Clarifications
Proposed Standard- A. Surtees
- M. West
- A.B. Roach
- June 2007
- IETF publication
- Transport Area
Abstract
This document describes common misinterpretations and some ambiguities in the Signaling Compression Protocol (SigComp), and offers guidance to developers to resolve any resultant problems. SigComp defines a scheme for compressing messages generated by application protocols such as the Session Initiation Protocol (SIP). This document updates the following RFCs: RFC 3320, RFC 3321, and RFC 3485. [STANDARDS-TRACK]
Abstract
This document describes common misinterpretations and some ambiguities in the Signaling Compression Protocol (SigComp), and offers guidance to developers to resolve any resultant problems. SigComp defines a scheme for compressing messages generated by application protocols such as the Session Initiation Protocol (SIP). This document updates the following RFCs: RFC 3320, RFC 3321, and RFC 3485. [STANDARDS-TRACK]
RFC 4465: Signaling Compression (SigComp) Torture Tests
Informational- A. Surtees
- M. West
- June 2006
- IETF publication
- Transport Area
Abstract
This document provides a set of "torture tests" for implementers of the Signaling Compression (SigComp) protocol. The torture tests check each of the SigComp Universal Decompressor Virtual Machine instructions in turn, focusing in particular on the boundary and error cases that are not generally encountered when running well-behaved compression algorithms. Tests are also provided for other SigComp entities such as the dispatcher and the state handler. This memo provides information for the Internet community.
Abstract
This document provides a set of "torture tests" for implementers of the Signaling Compression (SigComp) protocol. The torture tests check each of the SigComp Universal Decompressor Virtual Machine instructions in turn, focusing in particular on the boundary and error cases that are not generally encountered when running well-behaved compression algorithms. Tests are also provided for other SigComp entities such as the dispatcher and the state handler. This memo provides information for the Internet community.
RFC 4464: Signaling Compression (SigComp) Users' Guide
Informational- A. Surtees
- M. West
- May 2006
- IETF publication
- Transport Area
Abstract
This document provides an informational guide for users of the Signaling Compression (SigComp) protocol. The aim of the document is to assist users when making SigComp implementation decisions, for example, the choice of compression algorithm and the level of robustness against lost or misordered packets. This memo provides information for the Internet community.
Abstract
This document provides an informational guide for users of the Signaling Compression (SigComp) protocol. The aim of the document is to assist users when making SigComp implementation decisions, for example, the choice of compression algorithm and the level of robustness against lost or misordered packets. This memo provides information for the Internet community.
RFC 4077: A Negative Acknowledgement Mechanism for Signaling Compression
Proposed Standard- A.B. Roach
- May 2005
- IETF publication
- Transport Area
Abstract
This document describes a mechanism that allows Signaling Compression (SigComp) implementations to report precise error information upon receipt of a message which cannot be decompressed. This negative feedback can be used by the recipient to make fine-grained adjustments to the compressed message before retransmitting it, allowing for rapid and efficient recovery from error situations. [STANDARDS-TRACK]
Abstract
This document describes a mechanism that allows Signaling Compression (SigComp) implementations to report precise error information upon receipt of a message which cannot be decompressed. This negative feedback can be used by the recipient to make fine-grained adjustments to the compressed message before retransmitting it, allowing for rapid and efficient recovery from error situations. [STANDARDS-TRACK]
RFC 3485: The Session Initiation Protocol (SIP) and Session Description Protocol (SDP) Static Dictionary for Signaling Compression (SigComp)
Proposed Standard- M. Garcia-Martin
- C. Bormann
- J. Ott
- R. Price
- A. B. Roach
- March 2003
- IETF publication
- Real-time Applications and Infrastructure Area
Abstract
The Session Initiation Protocol (SIP) is a text-based protocol for initiating and managing communication sessions. The protocol can be compressed by using Signaling Compression (SigComp). Similarly, the Session Description Protocol (SDP) is a text-based protocol intended for describing multimedia sessions for the purposes of session announcement, session invitation, and other forms of multimedia session initiation. This memo defines the SIP/SDP-specific static dictionary that SigComp may use in order to achieve higher efficiency. The dictionary is compression algorithm independent. [STANDARDS-TRACK]
Abstract
The Session Initiation Protocol (SIP) is a text-based protocol for initiating and managing communication sessions. The protocol can be compressed by using Signaling Compression (SigComp). Similarly, the Session Description Protocol (SDP) is a text-based protocol intended for describing multimedia sessions for the purposes of session announcement, session invitation, and other forms of multimedia session initiation. This memo defines the SIP/SDP-specific static dictionary that SigComp may use in order to achieve higher efficiency. The dictionary is compression algorithm independent. [STANDARDS-TRACK]
RFC 3320: Signaling Compression (SigComp)
Proposed Standard- R. Price
- C. Bormann
- J. Christoffersson
- H. Hannu
- Z. Liu
- J. Rosenberg
- January 2003
- IETF publication
- Transport Area
Abstract
This document defines SigComp, a solution for compressing messages
generated by application protocols such as SIP [RFC-2543] and RTSP
[RFC-2326]. The architecture and pre-requisites of SigComp are
outlined, along with the format of the SigComp message.
Decompression functionality for SigComp is provided by a 'Universal
Decompressor Virtual Machine' optimized for the task of running
decompression algorithms. The UDVM can be configured to understand
the output of many well-known compressors such as DEFLATE [RFC-1951].
Abstract
This document defines SigComp, a solution for compressing messages
generated by application protocols such as SIP [RFC-2543] and RTSP
[RFC-2326]. The architecture and pre-requisites of SigComp are
outlined, along with the format of the SigComp message.
Decompression functionality for SigComp is provided by a 'Universal
Decompressor Virtual Machine' optimized for the task of running
decompression algorithms. The UDVM can be configured to understand
the output of many well-known compressors such as DEFLATE [RFC-1951].
RFC 3321: Signaling Compression (SigComp) - Extended Operations
Proposed Standard- H. Hannu
- J. Christoffersson
- S. Forsgren
- K.-C. Leung
- Z. Liu
- R. Price
- January 2003
- IETF publication
- Transport Area
Abstract
This document describes how to implement certain mechanisms in
SigComp (Signaling Compression), RFC XXX, which can significantly
improve the compression efficiency compared to using simple per-
message compression.
SigComp uses a UDVM (Universal Decompressor Virtual Machine) for
decompression, and the mechanisms described in this document are
possible to implement using the UDVM instructions defined in RFC XXX.
Abstract
This document describes how to implement certain mechanisms in
SigComp (Signaling Compression), RFC XXX, which can significantly
improve the compression efficiency compared to using simple per-
message compression.
SigComp uses a UDVM (Universal Decompressor Virtual Machine) for
decompression, and the mechanisms described in this document are
possible to implement using the UDVM instructions defined in RFC XXX.
RFC 3322: Signaling Compression (SigComp) Requirements & Assumptions
Informational- H. Hannu
- January 2003
- IETF publication
- Transport Area
Abstract
In wireless environments and especially in cellular systems, e.g. GSM
(Global System for Mobile communications) and UMTS (Universal Mobile
Telecommunications System), there is a need to maximize the transport
efficiency for data over the radio interface. With the introduction
of SIP/SDP (Session Initiation Protocol/Session Description Protocol)
to cellular devices, compression of the signaling messages should be
considered in order to improve both service availability and quality,
mainly by reducing the user idle time, e.g. at call setup. The
purpose of this document is to outline requirements and motivations
for development of a scheme for compression and decompression of
messages from signaling protocols.
Abstract
In wireless environments and especially in cellular systems, e.g. GSM
(Global System for Mobile communications) and UMTS (Universal Mobile
Telecommunications System), there is a need to maximize the transport
efficiency for data over the radio interface. With the introduction
of SIP/SDP (Session Initiation Protocol/Session Description Protocol)
to cellular devices, compression of the signaling messages should be
considered in order to improve both service availability and quality,
mainly by reducing the user idle time, e.g. at call setup. The
purpose of this document is to outline requirements and motivations
for development of a scheme for compression and decompression of
messages from signaling protocols.
Subscribe to SigComp
Get notified when:
- RFC changes to status, obsoleted by, updates, updated by, or subseries.
- New RFC added to this subject or below
- The subject was merged into another.