Atom
Atom syndication format and publishing protocol
Within this page
Atom RFCs (7)
RFC 8322: Resource-Oriented Lightweight Information Exchange (ROLIE)
Proposed Standard- J. Field
- S. Banghart
- D. Waltermire
- February 2018
- IETF publication
- Security Area
Abstract
This document defines a resource-oriented approach for security automation information publication, discovery, and sharing. Using this approach, producers may publish, share, and exchange representations of software descriptors, security incidents, attack indicators, software vulnerabilities, configuration checklists, and other security automation information as web-addressable resources. Furthermore, consumers and other stakeholders may access and search this security information as needed, establishing a rapid and on-demand information exchange network for restricted internal use or public access repositories. This specification extends the Atom Publishing Protocol and Atom Syndication Format to transport and share security automation resource representations.
Abstract
This document defines a resource-oriented approach for security automation information publication, discovery, and sharing. Using this approach, producers may publish, share, and exchange representations of software descriptors, security incidents, attack indicators, software vulnerabilities, configuration checklists, and other security automation information as web-addressable resources. Furthermore, consumers and other stakeholders may access and search this security information as needed, establishing a rapid and on-demand information exchange network for restricted internal use or public access repositories. This specification extends the Atom Publishing Protocol and Atom Syndication Format to transport and share security automation resource representations.
RFC 6721: The Atom "deleted-entry" Element
Proposed Standard- J. Snell
- September 2012
- IETF publication
Abstract
This specification adds mechanisms to the Atom Syndication Format that publishers of Atom Feed and Entry documents can use to explicitly identify Atom entries that have been removed. [STANDARDS-TRACK]
Abstract
This specification adds mechanisms to the Atom Syndication Format that publishers of Atom Feed and Entry documents can use to explicitly identify Atom entries that have been removed. [STANDARDS-TRACK]
RFC 5023: The Atom Publishing Protocol
Proposed Standard- J. Gregorio
- B. de hOra
- October 2007
- IETF publication
- Applications Area
Abstract
The Atom Publishing Protocol (AtomPub) is an application-level protocol for publishing and editing Web resources. The protocol is based on HTTP transfer of Atom-formatted representations. The Atom format is documented in the Atom Syndication Format. [STANDARDS-TRACK]
Abstract
The Atom Publishing Protocol (AtomPub) is an application-level protocol for publishing and editing Web resources. The protocol is based on HTTP transfer of Atom-formatted representations. The Atom format is documented in the Atom Syndication Format. [STANDARDS-TRACK]
RFC 5005: Feed Paging and Archiving
Proposed Standard- M. Nottingham
- September 2007
- IETF publication
Abstract
This specification defines three types of syndicated Web feeds that enable publication of entries across one or more feed documents. This includes "paged" feeds for piecemeal access, "archived" feeds that allow reconstruction of the feed's contents, and feeds that are explicitly "complete". [STANDARDS-TRACK]
Abstract
This specification defines three types of syndicated Web feeds that enable publication of entries across one or more feed documents. This includes "paged" feeds for piecemeal access, "archived" feeds that allow reconstruction of the feed's contents, and feeds that are explicitly "complete". [STANDARDS-TRACK]
RFC 4946: Atom License Extension
Experimental- J. Snell
- July 2007
- IETF publication
Abstract
This memo defines an extension to the Atom Syndication Format for describing licenses associated with Atom feeds and entries. This memo defines an Experimental Protocol for the Internet community.
Abstract
This memo defines an extension to the Atom Syndication Format for describing licenses associated with Atom feeds and entries. This memo defines an Experimental Protocol for the Internet community.
RFC 4685: Atom Threading Extensions
Proposed Standard- J. Snell
- September 2006
- IETF publication
Abstract
This memo presents a mechanism that allows feeds publishers to express threaded discussions within the Atom Syndication Format. [STANDARDS-TRACK]
Abstract
This memo presents a mechanism that allows feeds publishers to express threaded discussions within the Atom Syndication Format. [STANDARDS-TRACK]
RFC 4287: The Atom Syndication Format
Proposed Standard- M. Nottingham
- R. Sayre
- December 2005
- IETF publication
- Applications Area
Abstract
This document specifies Atom, an XML-based Web content and metadata syndication format. [STANDARDS-TRACK]
Abstract
This document specifies Atom, an XML-based Web content and metadata syndication format. [STANDARDS-TRACK]
Subscribe to Atom
Get notified when:
- RFC changes to status, obsoleted by, updates, updated by, or subseries.
- New RFC added to this subject or below
- The subject was merged into another.