[rfc-i] Data point [Re: Fwd: I-D ACTION:draft-hoffman-utf8-rfcs-03.txt]

Keith Moore moore at cs.utk.edu
Mon Oct 6 19:45:51 PDT 2008

My results on MacOS 10.5.5:

1.  The document displayed correctly using Firefox 3.0.3 and Safari 3.1.2

2. When saved to disk from Firefox, the resulting file did not display
correctly in Emacs or TextEdit.  Nor did it display correctly in an X
terminal window using "less -r filename".  (without the -r option, the
UTF-8 octets were represented as <XX> where XX were two hexadecimal
digits.)  It did display correctly in NeoOffice Writer.  It also
displayed correctly in a MacOS "Terminal" application window using "less
-r filename". 

(I didn't specify any particular format in which to save the file)

3. When I copy selected text from Firefox, the result pastes correctly
into Emacs, NeoOffice Writer, the Terminal application, and TextEdit.

4. When I tried to print the file from Firefox, nothing came out of the
printer.  The print spooler reported errors and stopped processing the
queue. The same thing happened when I tried to print the file from Safari.

(My printer is attached to an old iMac running a very old version of
MacOS X and a version of Ghostscript that knows how to talk to this
particular printer since Apple doesn't support it.  So maybe it's not a
fair test.  but then again, lots of people are using old printer
hardware, so maybe it is.)

More information about the rfc-interest mailing list